Dual Fifo dynamically disabled?

  the-george 18:40 29 Oct 2004

System - 900 Duron with Matsonic Mboard, 128MB Ram 20Gb Western Dig HD.
This is a friends system and it went belly up with lots of data on board. I fitted at old 500Mb HD and loaded Win98 then attached the 20gb drive as slave. Managed to save all his data to CD. Then decided to format and thorough scandisk the 20gb in Win 98 but scan disk froze part way through. When rebooted the 20gb drive not seen in Windows. Checked BIOS and all ok. Looked in Device Manager and found a problem. Dual fifo on IDE0 was dynamically disabled. Tried reinstalling drivers from 98CD but most up to date drivers were being used.
Went into BIOS to see if there was any mention of Fifo but could not find any.
How does one enable the dual fifo?

  Dorsai 18:53 29 Oct 2004

If The HDD not seen by the bois, it may have died, and your mate was smart/quick enough to get someone else involved before it stopped working. Did it make any funny noises when you managed to back up his stuff?

I suspect this as you say it worked, then stopped.

if WIn98 set up wrong, this should not stop the BIOS from seeing the drive to start with.

  the-george 19:01 29 Oct 2004

Thanks for response.
The Bios does pick up the hard drive ok and it is reported on the info screens that appear before or as 98 is loading.
So, I suspect this is a 98 problem as it occurred after the freeze up on scandisk.
Although there may be some problems with the hard drive I successfully transferred three CDs of data from this drive with no trouble.
I am currently reinstalling 98 on the smaller drive so will see if this corrects it.However, would still like to know if dual fifo can be re-enabled in case this does not sort it.

  the-george 19:31 29 Oct 2004

Just reinstalled 98 with 500Mb drive only attached and gone into Device manager. There is now no problem with dual fifo.

Am going to re-attach the 20gb gaed drive and see what happens. Will report back.

  Dorsai 19:33 29 Oct 2004

Bois detects drive, but it does not show up in Win98? That is a strange one, but i by-passed 98, went from 95 to ME. (and now have XP)

Other than unplugging it, rebooting, removing from device manager, shutting down, plugging back, perhaps on secondary IDE cable, and re-booting, i am not too sure.

But if you managed to recover the friends personal data, and it's only a 20gb HDD, is it worth the trouble? If yes, i have to admit to not knowing how to proceed with this, so over to the more knowledgeable others.

  the-george 19:51 29 Oct 2004

Reattached the 20gb hard drive and it is detected in bios as primary slave.
It still does not show in win 98. BUT it does show in device manager as working correctly but does not have a drive letter assigned and I cannot type one into the box.
Is this a case of having to add a line to the config sys file - something like lastdrive = z?
Seem to recall a thread like this some time ago. Will try and locate.

  the-george 20:03 29 Oct 2004

Could not find the thread but edited config.sys file and added line lastdrive=z.
However still no joy. The box for the drive letter is shaded grey.
Is this the correct entry?
Thought that drives A-E did not require this line anyway.
Any ideas anybody?
I know the drive is not that important but I do hate to get stuck and not know why!!!

  the-george 20:41 29 Oct 2004

Seeing as the original problem is resolved I will mark this thread as such but staret another re the drive letter problem.

  dan 11 21:09 29 Oct 2004

See if windows will re-allocate FiFo for the drive. Delete the entry for the drive in device manager and reboot. Let windows find it again and see if will allocate a drive letter for the drive.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires