dual boot xp and ubuntu 10.04 grub rescue error

  loonogs 19:39 12 Aug 2010

Have a dell latitude d610 with a new 250G hard drive, bios only sees 137G.
installed xp on the whole disk, works fine, then installed 9.10 from a cd that i have used on 6 other machines to dual boot.
seems to install fine and tells me to reboot after removing disk.
did this and get error "no such partition grub rescue"
this has never happened before on any of my other installations.
using xp disk removed partitions and reinstalled xp and 9.10 again same issue.
using xp disk removed partitions again, created 2 partitions. then using 9.10 disk installed ubuntu which seemed fine, but when i restarted it as asked got the same message "no such partition grub rescue". there is currently no windows on the laptop.
i am happy working with xp and commands to sort out problems.
no knowledge of linux commands, but would like some help as i need ubuntu
machine spec centrino 1.7Ghz, 2G ram, 250G harddrive

  Fruit Bat /\0/\ 20:16 12 Aug 2010

click here scroll about halfway don the page to read about rescue mode

  LastChip 21:17 12 Aug 2010

Can you clarify which operating systems you now have on the computer and which order you installed them?

Or are you OK now?

  loonogs 00:08 13 Aug 2010

first it was xp and then 9.10, with the problem booting up

done a complete similar reinstall and same problem
then using the xp disk re partitioned the hard drive and just installed the 9.10 on its partition, although it looked good as all the other installations did,, when restarting came up with the same error.
i have repartitioned the drive again and installed xp and left an unpartitioned area for the 9.10 installation again, which i will do when i get some info on.
good learning curve as all the other installations that i have done with these disks worked perfectly

  LastChip 03:12 13 Aug 2010

click here for an article one of my colleagues wrote recently.

It may help depending on the actual reason your system is not booting.

Do keep in mind though, the boot loader MUST go on the first sector of the drive you're using, if you want a dual boot menu.

Your machine BIOS will pass control to the hard drive and will ONLY look at that first sector for an operating system option. If it doesn't find one (for whatever reason), it will fail - Windows typically says; no system disc (or similar).

The other option you could consider, as occasionally (for no apparent reason), GRUB doesn't like your hardware, is to use Lilo as the boot loader. You should find this option under advanced when you get to the part of the installation (towards the end), when the installation tells you it wants to write the boot loader. I've used this option on occasions, when GRUB decided to go awol and give me grief!

Hope that helps, but come back if you've still got problems and one of us will try and suss it out.

  loonogs 21:52 13 Aug 2010

thanks for your response and time will try this over the next few days and let you know how i solved it

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

Political cartoons in 2017: Chris Riddell, Rebecca Hendin and Dave Brown on what it’s like to…

The best iPhone for 2017

Tennis : comment regarder la finale de la Coupe Davis 2017 ?