Drives missing -those yellow exclamation marks

  Ivor_Monkey 22:05 20 Aug 2004

My Toshiba DVD-ROM drive and LG cd writer cannot now be be seen on my computer. A yellow exclamation mark is against each in device manager.

I suspect the drivers are corrupt or there is something wrong with atapi.sys.

I have tried updating driver and uninstalling / reinstalling devices, but no still joy. When I try to update drivers, I'm told I have the latest. [It doesn't seem to expect drivers to be corrupted!]

Strangely, I can't find a driver for toshiba SD M1612 on the net. I note that Toshiba's website says that mo speical driver is needed.

"ATAPI CD-ROM and DVD Drivers
Toshiba's CD-ROM and DVD-ROM drives do not require any unique device drivers for Windows '95/'98/2000/XP/NT.
After installing your drive and re-booting, your system should recognize your CD-ROM or DVD-ROM.
Win '95/'98/2000/XP/NT Operating Systems support all Toshiba ATAPI CD-ROM and DVD-ROM drives natively."

Any help would be appreciated.

  jojiie 22:22 20 Aug 2004

Go back to device manager and open the + next to the IDE ATA/ATAPI contollers, next uninstall the secondary then primary IDE channels, restart your computer, if it freezes do a manual restart and the IDE's will reinstall

  Cuddles 22:28 20 Aug 2004

cd rom and dvd drivers are loaded from windows as they are gineric.

  jojiie 22:35 20 Aug 2004

I know they are but they can become corrupt, this has worked for me.

  woodchip 23:21 20 Aug 2004

Try replacing the MSCDEX file then Remove the drives from Device Manager and Restart the Computer

  Ivor_Monkey 09:59 21 Aug 2004

Thanks for suggesting things folks.

I hav tried both approaches, but still no joy.
I took MSCDEX from driversguide site.

But still can't see DVD and rewriter drives in My Computer and device manager shows yellow exclamantion. Oh dear.....

Any other suggestions

  sattman 10:34 21 Aug 2004

One tip that has worked in the past when this happens is to delete two registry keys under the CDROM device key. Be sure and back up your registry before messing with and and don`t mess with it if you don`t know what you are doing! The problem I had was that device manager told me my drivers were corrupted. Even after downloading new drivers, uninstalling and reinstalling device manager still claimed that the CD drivers were corrupt.
In order to resolve this problem you can try the following.
Go to Start/Run and type in Regedit
In regedit navigate to:
Make an export backup of the key and then delete the value entries in the right hand pane that are for Upperfilters and Lowerfilters.
Exit regedit and reboot your machine.

  Stuartli 11:14 21 Aug 2004

Have you checked that all the leads and/or cables are correctly inserted, including the IDE cable, particularly to the motherboard?

As has been pointed out, all such drives only require the basic Windows CDROM driver. Rewriters use software such as Nero to perform their tasks.

  Ivor_Monkey 14:30 21 Aug 2004

Thanks. I have checked cables leads etc. All seem sound. But still no joy. Is there nothing except to go into the registry?

Do any of the following give any lead?

Thanks again for your help.



Product: Windows Operating System
ID: 7
Source: Cdrom
Version: 5.2
Symbolic Name: IO_ERR_BAD_BLOCK
Message: The device, %1, has a bad block.

The device has a bad block of memory, which Windows attempted to read. The data might be missing or corrupted.

User Action
Do one or all of the following:

Retry the operation.
Clean the physical hard drive.
Use newer media.
Product: Windows Operating System
ID: 10005
Source: DCOM
Version: 5.0
Component: System Event Log
Message: DCOM got error "%%%1" attempting to start the service %2 with arguments "%3" in order to run the server:

The Component Object Model (COM) infrastructure could not start the named Windows NT service.

User Action
Review the Windows error code displayed in the message. If the error indicates that the system is out of memory, save your work, close other programs, and then try to start the service again. Alternatively, increase the amount of RAM installed on the computer.

If the message displays a system, server, or configuration error, contact your service support vendor.


I also had BSOD with something like atapi.sys adress..F86FF558 base at F86F3000 datestamp ....

Thanks again.

  Ivor_Monkey 14:53 21 Aug 2004

Sattman, I think your trick has done it! I followed your instructions and the drives seem to be back in action. Thanks. When you have time, perhaps you can explain what it was that I did!

Anyway, thanks to all who took the time to help. It was much appreciated.

Thanks again.

  sattman 15:50 21 Aug 2004

Pleased it worked for you.

click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Black Friday Deals 2017

How modern book design was influenced by illustrated manuscripts

Best Black Friday Apple Deals 2017

Les meilleurs logiciels de montage vidéo gratuits (en 2017)