Driver install - access is denied

  emmandelo1 12:45 03 Feb 2008
Locked

Hi, Desktop PC, WinXP. My internet stopped working suddenly. Device manager shows an exclamation mark next to my network adapter and reports that no driver is installed. When I try to reinstall the driver it finds it in C/windows/system32/drivers but then says access is denied. I have tried system restore, didn't work. Apparently this is something to do with the registry and permissions but I don't want to mess with the registry without knowing what I'm looking for. I am logged on as administrator. Any advice would be app

  sand_danser 13:06 03 Feb 2008

try running your m/b disk if you have it to re-install the driver for the NIC. CCleaner is a gr8 free tool for quick registry fixes too.
I would run your anti-virus progs 1st off though. Access maybe denied due to a virus running in your memory.
Spybot 1.5.2 is out there for free & should find any trojans that damage drivers in system32

Resore just evades the underlying issues.

  emmandelo1 13:35 03 Feb 2008

Have run the disk, it finds the driver on the disk but again says access denied. Have run A/V, no probs, Have run Spybot, no probs. Have run CCleaner. Still no joy.

  Technotiger 13:58 03 Feb 2008

This might help ... click here

  emmandelo1 14:04 03 Feb 2008

Thanks Technotiger, have already tried that as well. Didn't work.

  zarobian 14:09 03 Feb 2008

Go to device manager.High light your network adopter and select uninstall. When uninstalled then restart yor computer. It will reload the driver from your system32/driver folder if it is there.If not then then your mother boards cdrom will be required. If you know the makers of your network adopter then go to their site and down load the driver from there

  emmandelo1 16:24 03 Feb 2008

zarobian, could not even uninstall it. When I try it says failed to uninstall, this device may be required to boot up computer. Have also tried downloading the driver from the website and trying to install that, again it says access is denied!

  emmandelo1 19:34 03 Feb 2008

Okay, an update. Have tried to reinstall and delete in safe mode. Didn't work. Even created a new admin user account and tried it in that in case my profile was corrupted. Didn't work. Have used CCleaner, RegSeek, and Reg Scrub. Have run AV and AdAware and Spybot.

  Technotiger 19:49 03 Feb 2008

How did you normally connect to the Internet, via Router or Modem?

  emmandelo1 20:01 03 Feb 2008

I connect to the internet via a BT Voyager wireless router. At the moment I am connected by plugging a laptop adapter into the USB socket on the desktop

  Technotiger 20:12 03 Feb 2008

The reason I asked was because I am wondering if perhaps the Router needs to be re-set. To re-set the router, disconnect Power to router, then wait ten seconds, then re-connect Power to router.

Worth a try.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse draws on iconic heritage for a fresh brand identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?