A Drive not functioning

  malydee 22:42 21 May 2005

I have a standard floppy drive fiited in a Copmaq Presario using a n MS driver from 2001. When I insert a flopp I can not read the contents as the system diplays the contents from a previous floppy. When I try to open these files, I get a blank screen.
I have been into the M S help system and tried to update the drivers but I get the message that there are no further updates.
I have done a malware search on the A drive using MS AntiSpyware, Spybot and Spyware Doctor but it gets a clean bill of health.
The files displayed appear to be ghost copies left behind - do I need to change the hardware?

  Completealias 22:58 21 May 2005

Firstly I would try this open the device manager (right click my computer/ properties /hardware tab)

Expand the tree that states floppy disk controlers and then click on the entry there right click on this and select uninstall.

Once this has finished restart the computer when the operating system starts up again it will state found new hardware and install the drivers for it.

See if this fixes it

  malydee 13:10 22 May 2005

To Completealias
Tried your suggestion, unfortunately problem still exists. I have also tried uninstalling the A drive.

  DieSse 15:01 22 May 2005

The time has come to buy another drive methinks. They're vEry inexpensive.

  Stuartli 16:06 22 May 2005

My son is an IT support specialist - he once told me that the vast majority of floppy drive problems were due to a faulty or incorrectly fitted cable.

  Diemmess 16:32 22 May 2005

As an amateur, and no way a service engineer I know of 3 floppy drives all of which ceased to behave, and in each case had somehow become wrongly defined in the BIOS.

Every trick was tried unistalling, reinstalling, cables and so on, but in the end they were resurrected after making sure that the BIOS quoted Floppy Drive correctly including the capacity 1.44.Mb

I can't reconcile this with the weird memory of what was there last time on malydee's computer! Even so, it has to be worth a check.

  Fruit Bat /\0/\ 17:48 22 May 2005

Windows retains in its memory the contents of the disk and will not display the new contents in explorer or My computer until you use refresh or double click the drive icon.

  malydee 21:49 22 May 2005

I have checked the connection and it had moved away on one edge. I have removed the drive, checked the pins & refitted / connected. As a result the floppy drive is now no longer identified in the device manager list. I have gone into the bios which stated that the flopy drive was uninstalled and reset it to 1.44 Mb as recommended, saved the change and rebooted. The drive is still not installed. I have carried out this exercise 3 more times with the same result.

  woodchip 21:56 22 May 2005

Try removing Floppy controller in Device Manager and reboot

  malydee 20:16 25 May 2005

Unfortunately, none of the suggestions have worked. i am off to buy a new floppy drive

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Black Friday Deals 2017

How modern book design was influenced by illustrated manuscripts

Best Black Friday Apple Deals 2017

Les meilleurs logiciels de montage vidéo gratuits (en 2017)