DOS/NTFS problem

  chugby 21:02 06 Jul 2005

in the middle of trying to flash my DVD-ROM firmware on another PC, gone thru procedure with the helpdesk but they are now closed. Hopefully this will be a quick one to answer, running WinXP with NTFS and advised to run a MS-DOS floppy and then a NTFS.DOS program provided and extracted to floppy so that I can access the C: drive where the firmware is. Have just run the NTFS but cant seem to change to the C: Drive, just keeps showing the A: Drive. Any ideas?

  Completealias 21:31 06 Jul 2005

Download the NTFS boot disk fromclick here works for me

  chugby 11:12 07 Jul 2005

thanks for that, can now get in and view folder on the C: Drive. I'm supposed to be able to run the firmware by typing in FL3 but only seem able to view or copy folder it is in from this location, can you give me any advise? thanks

  woodchip 11:44 07 Jul 2005

For DOS you have to start the Computer with a Win98 Floppy boot disc, then when in DOS change the disc to the program you have to run and type name of program and hit enter key Ninth file down after downloading put floppy in comp and double click download click here

  Completealias 17:15 07 Jul 2005

Could you not put the firmware upgrade onto a disk and then boot with the floppy swap to the disk with the update on it and run it from there or is it too large.

Have a look in the directory where the firmware upgrade is and look for an exe file note the name of that and then try to run that.

If your in DOS when you do this the command is dir press enter to look at the contents of a folder note you need to be in that folder first

eg c:\firmware> dir (press enter) will list the contents of the folder firmware

  chugby 11:44 08 Jul 2005

thanks for replys, still not having any luck.
Tried the following:
1. Booting with windows floppy boot disk,
boots but cant use the NTFSDOS disk.
2. Booting only with NTFSDOS floppy disk but
can only seem to read C: Drive and not run the
the firmware.
3. Have put the firmware on floppy but not
able to access disk or run when in DOS,
if this because FAT file?

Probably not grasping this one very well, not done alot with DOS. Woodchip, my NTFSDOS only has 6 options so not sure on this.
Completealias, I couldnt access c:\firmware> dir from DOS. Any more help appreciated, have also listed response from BTC in case this might give some pointers for you to see where I'm going wrong.

BTC Response click here

You must reflash in DOS mode.

1.Please extract the enclosed DOS version firmware to a hard disk folder(such as c:\temp).
2.Make a MS-DOS boot floppy disk.
How to make a MS-DOS floppy disk?
a.Insert a floppy disk into floppy drive.
b.Double click My Computer Icon on desktop.
c.Right click floppy A choose Format.
d.Choose Make a MS-DOS bootable disk.
3.Turn PC off.
4.Unplug drive (power and IDE cable)
5.Boots on pure DOS environment (use MS-DOS boot floppy disk)
6.Plug drive (power and IDE cable)
7.Change to firmware folder(such as c:\temp)(If C is a NTFS file system please execute NTFSDOS enclosed)
8.Type f l4 (Drive connect as Secondary slave) or fl (Drive connect as Secondary master)
9.After flash complete please reboot, Windows will recognize drive then flash latest firmware by Liveupdate tool.


1.DOS flash utility program can't be used under DOS mode of Windows!

2.plug drive on IDE Secondary master or slave,not on IDE Primary master/slave

3.If your drive is an USB device, please return to dealer for the procedure.

  woodchip 11:59 08 Jul 2005

When you change the disc's after booting to DOS you have to type DIR press enter to see what is on the Disc. Then make a Note of the Name of Program you have to run, you may have to type it like this after you have changed the dos.

A:\>DIR /P this shows only one page at a time, this is because the files if too many to fit on one page will just scroll too fast to the last page and then you will be back at

A:\> you have to press enter after any typing you make in DOS

You then need to type the program and press enter.

You are in a whole new world in DOS

  chugby 12:14 08 Jul 2005

thanks for quick response Woodchip, will try again and let you know. regards

  chugby 19:20 19 Jul 2005

tried the re-flash with various firmware but could only manage to get the drive working about 50%, so decided in the end to buy a new one. Many thanks though for help given. Regards

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?