Dos, Windows XP and comms port. Problems!

  qwaszz 13:56 28 Feb 2004
Locked

I am trying to use a DOS program to control an encoder (a magnetic stripe card read/write unit) on comms port 1. The program will run fine on XP for inputting all the required info but as soon as this info is sent to the encoder via com1 nothing happens. The system works fine on DOS or Windows 3.1 9.* machines, the encoder has no drivers - it just plugs in and works! But not on XP.
Do the comms ports need to be set up, somehow, to work with DOS based programs or can XP be tweaked, somehow, to work with DOS. Or am I just trying the impossible!? Any help would be gratefully appreciated (The boss can't sort it so I'm looking for some brownie points!! PLEASE HELP!).
P.S. I know we should have windows based software and a USB encoder but that's another story. I need a fix for the equipment we HAVE got!!

  LastChip 14:23 28 Feb 2004

Are we to assume you have tried the above?

  qwaszz 14:28 28 Feb 2004

Yes, have done that but no difference.

  LastChip 14:30 28 Feb 2004

Is the reader used on a number of machines, or just one?

  Itwillblowyourmind 14:35 28 Feb 2004

It's not exactly dos, but it does have full use-ability, the bonus being that all the comm ports are controlled by XP, but you say what happens in dos.

start>Run>cmd
Press Enter.

  qwaszz 14:38 28 Feb 2004

LastChip, at any 1 site there is 1 reader and 1 PC. The problem is that as we acquire new sites we have to specify a non-XP machine, this is getting harder all the time.

  LastChip 14:52 28 Feb 2004

If you go into Device Manager; Ports (COM & LPT); and clicking on COM 1; Properties;

Have you tried;

1. Under General, make sure the port is not disabled?

2. Under Port Settings; Flow Control; handing over control to Hardware?

3. Click the Advanced button and reduce the Transmit speed?

Quite honestly, I have my doubts as to whether any of those will be the culprit, rather, it's just an old program that XP refuses to work with.

  qwaszz 15:25 28 Feb 2004

Thanks, tried all that but still no joy.

  LastChip 17:06 28 Feb 2004

I came across this click here which details some steps that can be taken to troubleshoot problems.

Two points worthy of note are, if the program requires 16 bit Virtual Device Drivers (VxD) it will not work and if the program needs unrestricted access to hardware, the same result I'm afraid!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

HP’s new Surface Pro rival is designed specifically for Adobe-using designers and artists

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?