Dos Programe under Win98SE Insufficient Memory mes

  dewskit 19:55 28 Sep 2006
Locked

I have recently had to completely clean install Wind98SE.

Everything seems to work as it should except for my Database Program which runs under DOS and repeatedly refuses to run in the Maintain mode claiming insufficnet memory.

Prior to the reinstall this Program has worked without problems for around five years, but now has me tearing my hair out.

I am sure it is something stupid I~ have omitted to do in either the start up files or in the PIF, but everything seems to look OK

Please anyone with a long memory out there?

Thanks in anticipation - I will be out for around an hour then back on line again.

Tony

  Jak_1 19:59 28 Sep 2006

What is the program? I take it that you have backed up the data files and that it worked under win 98 previously! Have you tried uninstalling and re-installing?

  dewskit 20:59 28 Sep 2006

Program is Data Manager Professional which runs under DR GEM on top of DOS.

As I said in my original posting, it has run for nearly five years on the same machine under Win 98SE. Apart from the reinstall of Win98SE, nothing else has been changed. Data was all backed up prior to reformatting

  dewskit 21:18 28 Sep 2006

Jak_1

Sorry, missed the last bit of your post...

I have uninstalled and reinstalled both GEM and the Program. Result is exactly the same message.

  woodchip 22:12 28 Sep 2006

How to manage DOS 640kb Memory, Go to Find under start button, Type Config.txt read it and follow it. Also look for MEM.exe double click the File and it will tell you what free memory you are using. the 640kb in DOS you can get more by following Config.txt about DOS. There are more .txt files. To find them in Find type *.txt

  dewskit 23:07 28 Sep 2006

Woodchip

Many thanks for that - I have printed out the Config.sys file and will take it to bed to read and try and fathom it!

Will report back once I have tried it out tomorrow

Thanks to everyone

Tony

  dewskit 10:22 29 Sep 2006

Woodchip

Sitting here with an ear to ear smile!

CONFIG.SYS was the problem as it did not contain the three magic lines

DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\WINDOWS\EMM386.EXE NOEMS
DOS=HIGH,UMB

After inserting these all is restored and I can get into the database without problems.

I suppose the next hurdle will be trying to get it running under WindowsXP... I wonder?

Many thanks again for pointing me in the right direction

Tony

  woodchip 12:17 29 Sep 2006

Don't forget 98se is my Operating System of Choice

  Diemmess 13:55 29 Sep 2006

.....It neither uses nor can run DOS based programs and their oh-so-necessary HIMEM components.
It can be overcome of course, but the work-around is long, tedious and full of pitfalls.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?