Do I really need SP2?

  emmandelo1 19:48 01 Nov 2004
Locked

Okay, I have Win Xp Pro on a stand alone home computer. Do not use it at all for gaming. For e-mail I use Outlook Express and I prefer to use Firefox rather than IE for browsing. I have AVG and Zone Alarm Pro. Regularly run Ad-Aware and Spybot.
I use Regseeker and Reg Compact. i defrag at least once a month and regularly back up everything. The machine is very rarely used for chat or messageing.
I have recently installed SP2 and ever since the whole thing has slowed down considerably. The other day I purchased Drive image 7 and discovered a well known incompatability with SP2. I have resolved this particular issue but it seems to me I could spend the rest of my life applying tweaks and fixes trying to get the computer back to its former glorious self. So... My question is.. Do I really need SP2 or shall I uninstall it and save myself a lot of grief? Your opinions would be appreciated.

  g0slp 20:15 01 Nov 2004

I would say yes. Most incompatibilities with existing hardware's drivers etc are easily sorted out, & the extra security that SP2 gives is well worth it.

If you look at some of the recent threads on peoples' machines being accessed by spammers or worse, any extra help in keeping your computer safe is essential.

The only problem I had putting SP2 into 2 machines was having to update the software for Nero on one.

However, it's up to your good self.

  Irishman 20:32 01 Nov 2004

Like you I had problems with SP2 when I first installed it. I then formatted my hard drive reinstalled XP and immediately installed SP2 before installing anything else. Working perfectly ever since.

  Dorsai 20:40 01 Nov 2004

Irishman has, i think, hit the nail, very squarly, on the head.

From my experiance with SP2. I tried it, it went west, without warning. I did what he did, Reformat, install XP, Install Vital drivers to get PC working, Install SP2..So far One happy Dorsai.

  emmandelo1 21:08 01 Nov 2004

Thanks for your response. As I have only just a few weeks ago done a format and reinstall I am loathe to do it again. It's interesting that all respondees (is that the right word..?) have had problems. I think I will uninstall for now and when I next format and install I'll load SP2 on first.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone