DNS error through wired connection, WLAN OK?

  Dipso 21:32 13 Feb 2006

Title not the best but here goes...I setup a Netgear DG834G modem router for a friend. I configured the router using a wired connection between the PC and the router. I got the connection up and running and could access the net fine. The last thing I did on the wired PC was was change the routers default password.

Then I moved onto the wireless, again this worked fine so I set up WPA encryption.

I went back to the wired PC to access the router to set up MAC addressing and found I couldn't access the router. I typed in and got the login box but the page just hung. I tried to open IE6 and got a Page Cannot Be Displayed DNS error. I rebooted the PC after some head scratching and got a Limited Connectivity message for the ethernet connection. Then I found I couldn't get to at all.

I Googled for some answers and followed advice to take the router back to default and start again but got the same result.

The WLAN was still available both before and after resetting the router and I could still access the router through the wireless connection.

Amongst various other things I tried to flushdns and registerdns but got the same problem.

My friend lives a good 20 minute drive away and I need to know what I'm looking for when I get time to go back. I presume the problem is with his PC so I could bring it to my house and attempt to resolve it here as I would have more time. I can't understand why it was working one minute then not the next. Where should I start?

  keewaa 21:48 13 Feb 2006

Are you talking about 1 PC? If you have a computer wired and also use wireless without disabling the other, it is likely to cause an IP conflict. Use one at a time and disable the other before using the other (in network connections right click disable).

To fix go to a command prompt and type


If this doesn't work maybe the TCP/IP stack is corrupted and can be fixed with click here but try the IPCONFIG comands first.

  Dipso 22:06 13 Feb 2006

Knew I would word it badly...no, I was setting up the router to allow access from 1 wired PC and a wireless laptop. I just used the PC to set up the connection then when I went back to it to tweak the security I couldn't login to the router.

I did try all 3, IPCONFIG /RELEASE
IPCONFIG /FLUSHDNS but no improvement. I was reading another post that suggested the Winsock fix, looks like this is the best thing to try nex then.

I just don't get why it just developed the error, I hadn't done anything to prompt it???

Cheers for now...will post back when I've tried the fix.

  keewaa 22:11 13 Feb 2006

AFter changing the router password did you switch off everything, reboot the router, then turn the PCs on again ... I think a pw change might require a router reboot.

Also check for a firmware upgrade for the router on Netgear's site.

  Dipso 22:22 13 Feb 2006

No I didn't reboot the router, you have to reinput the new password after clicking "Apply" so I presume this is all that is required with this router but like I say I can still access the router no problem through the wireless connection so it looks like it's just the PC that's the problem.

The firmware isn't the latest (next to) but I am running the same and it's very stable for me so I don't want to go down that route just yet. Plus as it stands I would have to download the firmware update on a wireless connection and that's not a good idea is it.

  keewaa 22:24 13 Feb 2006

Any chance you enabled MAC filtering and only registered the wireless MAC or set up an IP block on the wired PC? I would have a look at those areas in the router.

  keewaa 22:29 13 Feb 2006

Some things to try :

Also possible is a lose network cable or connection , a dud or faulty cable, and same for the PC NIC.

In Internet options connections is it set to never dial and LAN setting try auto & not auto.

Check network connections for info on the connection, also check device manager for any yellow triangles.

what does IPCONFIG /ALL DISPLAY on the PC ?

Try a different cable, also try wiring the laptop in (first disable wireless to avoid Ip conflict)

  Dipso 09:04 14 Feb 2006

Thanks keewaa, will try all those suggestions first and let you know how I get on.

  Dipso 21:21 15 Feb 2006

Problem now resolved. I checked the settings, they were all OK.

I swapped the cable and the connection sprung to life, which led me to believe it was that, but I thought I would just retry the original and that also connected.


I tried the laptop and found that I was now getting DNS errors on that! OK somethings conflicting somewhere...

So I removed the network cable to the PC and shut it down and turned off the wireless card on the laptop and shut that down.

I booted the PC first and reconnected the cable and allowed it find its IP address. Then I booted the laptop and turned on the wireless card.

Bingo! There seemed to have been some conflict between the IP addresses as though they were both trying to use I'm not entirely sure how this had happened but it now works.

Thanks for your suggestions.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?