DLink DSL G624T

  malcolme 20:27 10 Jul 2008
Locked

I have messed up firmware upgrade, cannot access router through wired or wireless. Tried resetting router, but did not work. Is it possible to recover the router or should I bin it.

  ambra4 02:55 11 Jul 2008

Try this and see if it will reset the router and allow you access, no guarantee that it will work on

your router, have work on other D-Link routers before.


Leaving the power cable connected

And removes all ethernet cables and the phone line from the router

“Do Not Remove The Power Cable”

Press and hold down the reset button for 15 seconds

Remove the power cable from the router while still holding down the reset button for another 30

seconds with the power cable removed

While still holding down the reset button plug the power back into the router

Wait for another 45 seconds and then release the reset button.

Wait for another 10 seconds and remove the power cable

Keep the router unplugged for 60 seconds then plug back in the power cable and all other cable and

check if you can access the router

If still no joy, you can bin it or return it to D-Link, you may get a free replacement or they'll sort out

the problem

  grey george 20:40 11 Jul 2008

On my d-link you have to hold the reset button for 20 seconds for a standard reset.

  malcolme 21:56 11 Jul 2008

Thanks everyone, tried everything it looks if it's time for a new one.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Ryzen news - release date, UK price, features and specifications

The pulp art of 80s computer game magazine covers

Best value Mac: Which is the best £1249 Mac to buy

Comment faire des captures d’écran sous Windows 10 ?