display driver installation causing high cpu usage for the last 20 mins..?

  theDarkness 01:16 24 Oct 2011

I tried to switch user without logging off, and the display went completely black and hanged indefinately. Microsoft-Windows-Kernel-General error-"An I/O operation initiated by the Registry failed unrecoverably.The Registry could not flush hive (file): '\SystemRoot\System32\Config\SOFTWARE'.

I was not installing anything at the time. After 30 mins, I forced a switch off and restarted. A message popped up on reboot, that it had "found a solution to my problem"-and offered me to update my display drivers. Curiously, the drivers on offer were already installed beforehand (an intel vista and win7 compatible gfx driver), and on deciding to give them a reinstall (its better than a black screen every time I want to switch user), I now have my system giving me the message that there was a problem on install. Upon checking the taskmanager, the system cpu is now on 60% in total indefinately as it tried to install these drivers. I thought it might be a UAC issue preventing the installation, but that was turned off before the first black screen (I see black screens ALOT with UAC). You can see everything that is running on my system from the image below-the hard drive has been going mad for the last 20 minutes, as if its still trying to install


  theDarkness 04:00 24 Oct 2011

In the event viewer I have multiple non stop entries for the time its set to a black screen after switching user (ive just been in another for over 50 minutes-I thought the system might finally correct itself-I was wrong). They all show "Source: System, Application popup:\SystemRoot\System32\win32k.sys failed to load" every few seconds. This is when the processor seems to be running fairly high, and evidence of this may be in two single events I have that differ to the above:- "Source: Microsoft-Windows-Kernel-Processor-Power Description: The speed of processor 0 is being limited by system firmware. The processor has been in this reduced performance state for 48 seconds since the last report."

Ive tried searching for a fix. This post suggests I should try changing firewall:- http://www.pctools.com/forum/showthread.php?55622-Black-screen-when-using-fast-user-switch-in-vista

Some other forums suggest its a hardware issue that might not be possible to fix in vista and 7, as that may be down to the manufacturer updating its graphics drivers and nothing more:- http://social.technet.microsoft.com/Forums/eu/w7itproui/thread/80b7b992-897d-4425-9ed8-29901404d529

I dont think Ill be using that automatic update for any graphics drivers anytime soon again (or switching user), but both the generic graphics drivers and manufacturers drivers have the blank screen effect whilst switching :( Ill try a change of firewall or switching off other system protection to try and work out if that could be the main cause. I doubt thats the problem. Sending the error report for each log gives no further info. Has anyone else had an issue in switching users in vista and 7? Not that im suggesting you try it, as you may then be forced to watch a blank screen for more than a few minutes with your processor at the max, before being forced to do an auto shutdown :(

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?