disk check for consistency each time i boot up

  The GnoMe 14:15 17 Dec 2003
Locked

Hi all, i have just had to reinstall my linux distro on my other partition.
I run win xp pro and mandrake linux 9.1.

each time i come to boot up the computer into xp i get a blue screen (not of death) with the message that one or more of my disks need to be checked for consistency, it then goes on to check my d drive (labeled documents)

it then boots into xp fine.

it does not do this when booting into linux

anyhelp is as always greatfully recieved.

ps. i have been running linux along side win xp for months with no problems until i reinstalled it

cheers

G

  Chegs ® 14:55 17 Dec 2003

Something in XP isn't shutting down correctly,this would explain the checking as it reboots.Try command prompt scandisk/chkdsk with your XP cd in the drive,see if anything is missing/corrupt.

  Stormpool 15:32 17 Dec 2003

In windows XP

Open up a command prompt

Start - run - type 'cmd' - ok

On the C:\ prompt - type

chkdsk /f

and press enter. Confirm to run chkdsk on next reboot, hopefully if it does find any errors it should fix them at the same time.

Then try a few subsequent reboots to see if it's still finding inconsistancies.

  Taran 16:09 17 Dec 2003

You can disable it if you like, assuming you are comfortable about the integrity of your hard drive.

I'd imagine you may find you have a bad sector or two or your machine may not be shutting down corrcetly, so you may want to make sure all is well before trying the following.

You have to edit the registry and you can find details at this link click here

All this does is stop chkdsk running at every system start. It doesn't fix any disk or shutdown problems, so you should manually run chkdsk with all the necessary find, fix, repair switches to make sure your disk is 100%.

You may also want to get a copy of MemTest and check your RAM with a full scan. Shutdown problems are difficult to diagnose at best, but faulty RAM is one of the main culprits for system instability and MemTest offers a quick method to rule that out as a possible cause.

  The GnoMe 23:47 17 Dec 2003

no it is still doing it it says the volume is 'dirty'

i have tried to disable it but the key i created only seems to make it start immeadiately instead of giving me 5 seconds to stop it

any more ideas

  hugh-265156 23:58 17 Dec 2003
  The GnoMe 15:03 19 Jan 2004

thanks for all your help, i have tried all of your suggestions and nothing has helped

taran i edited the registry and created the key but it did not disable it all it did was take the time you have to wait until it starts (ie hit any key in ? seconds) down to 0.

i have even tried to empty that partiton and then format it, but i get the message that something is running so it cant format it,
i tried it in dos with to no avail

can anyone else help me

i thought it might me partition magic but i have now uninstalled it and it still hasnt helped

any help is appreciated as always

  The GnoMe 18:53 19 Jan 2004

when i come to format, it says that the drive is in use? i turned off system restore but it still says the same, i even tried safe mode but it is the same

can anyone please help me find out what is running so i can format the drive to see if this will solve my problem

  The GnoMe 07:32 20 Jan 2004

bump up to top

  The GnoMe 18:28 20 Jan 2004

bump, please??

  Chegs ® 18:37 20 Jan 2004

Value Data: Time in Seconds or 0 to disable (default = 10)

From Tarans link,I used these pages to remove my "Search for..." in XP earlier,and its wrong in that it states 0 disables it,but its actually 1 to disable.Try this,and then see if the drive is accessable to format,as it could be this thats running and stopping you from formatting hdd.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?