disastrous XP sp3 installation

  Les53 10:17 07 Jun 2008
Locked

well i thought it would be a good idea to keep up to date with the latest sp3, but alas it hasn't gone to well. The first computer i tried it on got over 50% done then an error message appeared stateing access denied. the pc tried to recover from this but when rebooted it was slow, device manager is missing etc etc.

The second computer which was a newer machine the same thing happened but this time it idn't recover as well.

I am running sp3 on the 1st computer again and it has been on stuck atstarting services before install for nearly an hour.

The second one i am running the repair option as it wouldn't boot, that is stuck on initializing configuration for about the same time.

any ideas to get these pc back to normal.

I was going to use the sysytem restore on the one that's working, is that a good idea.

  Halmer 10:20 07 Jun 2008

but as my Windows XP PC has not installed SP3 via Automatic Updates I have avoided it like the plague on the assumption that it's not needed.

Totally confused to be honest.

  Les53 10:27 07 Jun 2008

the pc running the sp3 i noticed in services that fixfcc was taking 98% of the processors power, i stop this and it is now continuing, i did the fix that was suppose to sort out access denied , so fingers crossed for that one.

i am quite confident on computers but the general public are going to be well let down on this sp3 update.

  chub_tor 10:32 07 Jun 2008

Had you already installed IE7 before changing to SP3? This can cause a problem click here

  Fruit Bat /\0/\ 10:33 07 Jun 2008

You anti virus / antispyware may be blocking access to the registry.

1. Make a backup of your registry.

2. Download and install subinacl.exe.
click here

3. Create a file called reset.cmd with Notepad. Copy the text below into the file reset.cmd and run reset.cmd with administrative rights (it may take a LONG time):

cd /d "%ProgramFiles%\Windows Resource Kits\Tools"
subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f /grant=system=f
subinacl /subdirectories %SystemDrive% /grant=administrators=f /grant=system=f
subinacl /subdirectories %windir%*.* /grant=administrators=f /grant=system=f
secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

4. Reboot at SAFE MODE and try install SP3 again.

  Les53 10:40 07 Jun 2008

fruit bat

i did that to the letter last night, when i click on rest.cmd, it just flashed quickly can i assume that worked.

What about that repaid stuck any ideas/

  Les53 10:52 07 Jun 2008

well ,it's just stopped at access denied again, even though i did the above. all i can do now is forget sp3 and do a system restore back to before i got involved.

the other pc I was have to do a clean install.

well done Microsoft.

  Les53 11:12 07 Jun 2008

Computer just rebooted, lots missing including device manager.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?