Direct X problems and no playback device

  Dipso 12:40 12 Mar 2004

I have been having various problems but have narrowed them down to DirectX issues and the fact that there is no preferred device in Sound Properties. The box is greyed out and just says "no playback device".

I reinstalled DirectX which solved a lot of .dll errors I was getting (passed all tests in dxdiag)but when I tried to sort out the sound problem by removing and reinstalling the sound card, the DirectX issues DDRaw.dll errors, kernel32 errors returned.

I tried reinstalling DirectX again but this time it didn't have any effect.

I have tried updating the sound cards drivers but that didn't help.

I am going to try and reinstall WinME over itself from the c:\options\install folder.

If that fails format and reinstall. Before I do this, has anyone ever come across this before and can you suggest any other course of action?

  anon1 12:47 12 Mar 2004

Faulty soundcard maybe?

  Dipso 12:57 12 Mar 2004

Its onboard, so is the only way to see if this is the case, to buy a seperate card?

  Dipso 20:51 12 Mar 2004

Forgot to mention, I also get this when going into Control Panel, Sounds, Audio "Driver is enabled but inactive due to an unknown problem".


  gudgulf 21:09 12 Mar 2004

Beg,borrow or buy a soundcard--if that works problem solved.

I take it that your onboard audio device is listed in device manager----try deleting/uninsatalling it from there and rebooting.If windows doesnt detect it again this could also indicate failure of the device.

  Dipso 21:26 12 Mar 2004

Yeah, onboard sound listed in device manager. I have removed it and reinstalled it, Windows detects it each time but after reboot there is still no speaker icon in systray and I still get the inactive driver message.

  gudgulf 21:38 12 Mar 2004

What about system restore?

Failing that I would agree that a reformat/full reistall is worth doing---if only because I've been there,done that too.

Same problem , same windows and same frustration. lol

  Dipso 21:44 12 Mar 2004

That's another one of the many problems with this system I'm afraid, System Restore won't work, I tried that first. Oh well, looks like it's a reinstall. Thanks for your help anyway.

  Dipso 22:06 13 Mar 2004

In case anyone has a similar problem (no playback device in audio properties) and searches for a possible solution. I seem to have resolved the problem by installing Windows on top of itself.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

Political cartoons in 2017: Chris Riddell, Rebecca Hendin and Dave Brown on what it’s like to…

The best iPhone for 2017

Tennis : comment regarder la finale de la Coupe Davis 2017 ?