Direct 3d not working

  User-18A4CB7E-F12F-4029-80E43B7C3B00B297 18:49 11 Jan 2004

I hope someone can help here.
I recently installed a PNY Nvidia GeForce Fx 52000 Ultra card. I was advised that it was quite a simple task.
The motherboard is a sis M10L series with a Duron chip with integrated graphics. The installation book chirpily advised unintalling the old graphic drivers before installing the new ones, but the computer refused to do this so I deleted them myself (keeping them in the recycle bin in case).
The graphic card now works but only on some games and the computer refuses to recognise direct 3d.
Any ideas?

  hugh-265156 19:01 11 Jan 2004

click start/run and type dxdiag click ok

click the display tab and test direct draw and direct 3d here.are there any errors reported?

also check acceleration is enabled.

try downloading the latest drivers for the graphics card click here then update direct x to version 9 click here

if your previous card was a different brand of to nvidia try reinstalling the games that dont work as they may be set up for it.

  gudgulf 20:28 11 Jan 2004

Also check whether you need to disable on-board graphics in BIOS or with a jumper on the motherboard.

Have a look in the device manager to see if there are any problems with the graphics adapter
shown there.

Thanks for the advice.
Dxdiag reports failiure at startup 8 0x8004005 - generic failiure and 0x887608c error code
i've no idea what this means.
Also one game fails to load because of a failiure to launch direct draw exe.
There seem to be nothing wrong according to the device manager although Sis graphics port is still there. Should I click the remove button for this?
On board graphics doesn't seem to be in BIOS
The installation guide advises downloading a vga/vxd driver from the motherboard manufacturers, but no matter where I look there doesn't seem to be such a thing.

  hugh-265156 01:33 12 Jan 2004

to disable the onboard,look for "shared memory" in your bios(probally under the advanced/chipset or similar menu somewhere)

you may have an "sis accelerated graphics port" and "sis pci to isa bridge" listed in device manager under the system devices tab because your mobo has an sis chipset.does it?

if so leave this as is and look for shared memory in the bios.

  gudgulf 01:48 12 Jan 2004

You can also simply disable the onboard graphics from the properties option for the adapter in device manager.

As for the direct draw error--Ive had problems with the game Halo--same error message

Make sure the refresh rate for your display is set to adapter default and not optimal.After much tearing out of hair it was only that which was causing the problem.

I can't find "shared memory" anywhere, nor can I find "onboard graphics". There is "sis accelerated graphics port" in the device manager, but no "sis pci to isa bridge" but there is sis cpu to pci host and sis pci to LPC bridge.
Unfortunately, changing the refresh rate made no difference. Have I deleted enough sis drivers? There are still some left but I think they're for sound.
When I disabled the Graphics accelreator port, I had to reinstall the old files for the motherboard - it then overides the nvidia drivers.

  hugh-265156 22:42 12 Jan 2004

it may be a jumper needs setting if the mobo is more than a few years old.

i just re read your posting again.sorry to contradict you but are you sure its an sis motherboard? i was under the impression they only made chipsets and graphics here

your motherboard by the sounds of it may well have an sis chipset on it though but i cannot find any info on "M10L"

download and install aida32 personal etd click here install it and click "computer/summary" then scroll down to "motherboard name"and "motherboard chipset" see also "bios type" to identify the exact make and model.

once you have identified it we may be able to get some more info for you.sorry cant help you anymore.

Thanks for that - sorry to have given you wrong info.
The motherboard is PCChips M810LR
Chipset - SIS 730S
Bios Type AMI 01/03/03 (no name appears, but the manufacturer is American Megatrends)
Also I've found on the aida32 that the Graphics controller status reads "disabled" as does AGP status.

  hugh-265156 16:16 13 Jan 2004

"12. How do I disable the onboard VGA?
When you insert an AGP card the motherboard should detect this and automatically disable the onboard VGA. In BIOS Setup, under PCI / Plug and Play Setup page, ensure that the Primary Graphics Adapter is set to PCI. You may also have to manually uninstall the VGA drivers" from click here

get the latest generic sis 730S ide/agp drivers(work with most motherboards) "agp117.exe" and ""
from click here

also check acceleration is enabled: right click the desktop/properties/display/settings/advanced/troubleshoot and drag the slider to full.

I tried these and when I restarted the computer the screen was garbled, even the pointer was a patchwork. I manually uninstalled the vga drivers again and the computer is behaving as before.
Open GL works very happily. Aida 32 tells me that AGP is disabled.
The IO read data port for ISA Plug and PLay enumerator has a red traffic sign and the description "input-output range" both used by "scondary ide controller" and sis 5513 dual pci ide"
Could this be a cause of the problem?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?