Digital Camera & Camcorder connection problems

  Big John P 18:08 28 Feb 2006
Locked

Hi All.
New subscriber today. Hope anyone can help. OS Win XP Home, nVidia 5600 nforce2 graphics. I Have a Sony Cybershot connected to USB. JVC Camcorder connect via Firewire. Both cameras previously worked well downloading images and movies. When connecting the Sony still camera, error message says no drivers found. XP has always sorted this out its self. Tried using the supplied disc to re install and also tried updated drivers from Sony. Still no joy. JVC Camcorder when connecting to Fire Wire port opens Movie maker but prompts this message, Moviemaker has encountered a problem and will have to shut down. I am also experiencing connection problems with USB memory sticks, again not found.
I have tried re locating the usb and firewire cables to different ports but still no joy. The ports appear to be live as my broadband connection operates through them.
I have used system restore, but this has also failed to cure the issue. Can anyone offer a starting point. All advice greatly received.

Big John

  recap 19:06 28 Feb 2006

XP has a tendency to create an error if there are old driver on the system. Unistall all the drivers for your camera and camcorder. Do a hard reboot, then reinstall everything again.

  Big John P 07:49 01 Mar 2006

Thanks for the advise recap. Will try today.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?