DHCP not working for wired LAN

  Batch 12:12 10 Apr 2013

I have a relatively new laptop running Win7 HP x64.

I have two brands of router. A Thompson TG585v7 - everything works fine on that.

On the other router (a 3Com 3CRWDR101A-75 which I prefer and so tend to use), the wireless adapter connects to the router OK using DHCP and picks up its IP address fine.

But the wired adapter doesn't seem to pick up the IP address and so appears to use a fixed default (presumably supplied by RealTek - the adapter manufacturer). Not unreasonably, the router objects to this IP address as it is not in an acceptable / known range (treats packets as SMURFs). I assume it can't be the settings on the lappie as it works fine with the other router (and anyhow I've checked the settings to ensure that it is set to obtain IP address automatically).

By way of contrast, on my 3 other computers (desktop, lappie, netbook all on XP SP3) wired and wireless all work fine with either router.

Any ideas?

  Batch 13:16 10 Apr 2013

Problem solved (after a fashion).

One of the reasons I prefer the 3com router is that it is very flexible and provides reasonably detailed logs.

On the 3com router I had set-up the local network IP range to be in the 172.27.xxx.xxx block (perfectly legit - see http://en.wikipedia.org/wiki/Private_network). This has always worked fine before.

On the Thomson (as supplied in a pre-set and locked state by my ISP) one cannot change the local net range and so are stuck with 192.168.xxx.xxx

Changing the 3com router to be in the 192.168.xxx.xxx seems to have overcome the issue.

  Batch 13:23 10 Apr 2013

Link again


One of these days PCA will get it right!

  Batch 11:46 11 Apr 2013

Thought about this some more and it just didn't seem right. Although changing the IP address range used by the router for DHCP seemed to overcome this issue, I wasn't happy with the rationale as to why it had happened.

Having slept on it I wondered if it might be to do with me Leaving The HomeGroup and Disabling HomeGroup - whilst the wired network adapter wasn't in use (but the WiFi adapter was in use).

I did a restore and tried again with both adapters active and it all worked fine this time. It seems that leaving and/or disabling the HomeGroup when an adapter is not active leaves that adapter somehow still tied to that HomeGroup and unable to connect properly. Windows then uses the as per:-

"If a DHCP server does not respond after several discover messages are broadcast, the Windows computer assigns itself a Class B (APIPA) address. The Internet Assigned Numbers Authority (IANA) has reserved for Automatic Private IP Addressing. As a result, APIPA provides an address that is guaranteed not to conflict with routable addresses."

So now I know.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?