DHCP not working on Belkin Router

  danielgent 14:41 04 Nov 2009

Tried to setup a Belkin Wireless G plus Router. 12 months old but never been taken out the box. Connected the laptop to the router by ethernet cable. Vista didnt recognise the network and on the Vista internet status page the world was greyed out (even though the routers internet light was green). Ipconfig/ all showed the ethernet card wasn't being given a local IP address and instead was getting one of the those 168.x.x.x. ones.

Went through the wizard on the CD that came with the router and it asked me to reboot the laptop (saying it would restart after reboot). It never restarted after a reboot so I thought I'd do it manually (always much better doing it manual anyway!). I had to go through the manual to find the router had the IP address
So I gave the laptop the static IP address It could now see the router (when connected by ethernet cable) and the vista internet connection page showed the internet as a green globe. Google and etc all worked fine. Then when I tried to set the wireless network up, same thing happened. Had to give the wifi card the address for it to work. When setting the IP addresses back to automatic (e.g. assigned by DHCP) they didnt work. Couldn't ping the router as private IP addresses weren't being assigned

So the laptop is working fine at the moment but it can't be taken anywhere that has a router on the subnet (is that the right terminology?).

I messed around in the setup pages of the router turning DHCP off (it was already on). rebooting, turning back on, etc a few times. Still no luck.

Is this router broken in some way or am I doing something wrong?

Much thanks for your help,
Dan Gent

  mgmcc 19:06 04 Nov 2009

>>> So the laptop is working fine at the moment but
>>> it can't be taken anywhere that has a router on
>>> the subnet (is that the right
>>> terminology?).

Terminology is spot on! As you say, in order to use the Laptop with a router that operates in a different Subnet, you would either have to change back to automatic IP addressing, or give it a new fixed IP address to work with in the new Subnet.

You could try "hard resetting" the router back to factory default settings and setting it up again from scratch, which might sort its DHCP problem. Otherwise it sounds as though it is faulty. There might be updated firmware available on Belkin's website which you could install as another option.

  danielgent 22:32 04 Nov 2009

I tried resetting it for factory defaults first thing. I checked the manual and it said to hold down the reset button for ten seconds, so I did. Maybe I'll hold it down for 20 seconds or even longer!

Very good idea about the firmware. hadn't thought about that but its very easy to update isn't it (not tried but seen the link on the setup page). i'll try emailing Belkin and lay the blame at their door :^)

Thanks for the help Mgmcc, no one else on any forums has been helpful at all!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?