The Device is not ready

  Cesare 17:08 12 Oct 2006

Win 98; when I put in a disk in 'D' or 'E' I get, The Device is not ready. What can I do please ?

  johnnyrocker 17:13 12 Oct 2006

first off try a reboot then see?


  Cesare 18:25 12 Oct 2006

tried a reboot but same result I am afraid.I will try Device manager and see what's cooking

  Diemmess 18:31 12 Oct 2006

Assuming D: and E: are alternative CD devices?
Unless one is a DVD, Win98 should be able to replace with good drivers if you delete them in device manager and then reboot.

Is it possible that you have been inside the box and disturbed the data cable at the motherboard?

  Cesare 19:54 12 Oct 2006

I have been trying all sorts with no luck. Tired out. Unable to continue. Will try again tomorrow. Thanks

  Cesare 08:05 13 Oct 2006

Here I am still trying. When I put in a disk in D or E, I get; D:\ is not accessable. The device is not ready.
My D is Creative DVD 5240E-1 and E Atapi CD-RW52XMax. Does Network Adapter have anything to do with this ? Because in Devise Manager/ Ndis2 Driver it says: The Ndis.VXD device loader for this device could not load the device driver. I am lost ! Help appreciated.

  Diemmess 09:18 13 Oct 2006

I'm not competent to answer the Network problem and I no longer use 98SE....
...... but when I did..... I occasionally used (when desperate) a recovery method from upset Windows.

It will only work if used within 5 days of the trouble appearing.
If you are inside that limit - try the following

Reboot and keep tapping the F8 key from before it starts to load Windows.
A DOS like menu with options will appear.

Choose Command Prompt Only

When the screen changes to just C:> showing, type "scanreg /restore" (No quotes and make sure of the space after scanreg) ... Enter

The computer will offer the last five dates when it has booted successfully, and you should choose a date earlier than when you first had trouble.
This is Friday 13th, but if you choose the earlier system the computer will automatically restore the registry to that date when all was working and
Hey Presto!

  Cesare 14:38 13 Oct 2006

My fault has been going more than five days unfortunately. Thanks anyway for your kind help.

  Diemmess 17:35 13 Oct 2006

System file checker:
I don't know if this is part of 98SE but if it is, then have your Installation CD handy and
Start> Run> then type in - sfc

If it runs, it will scan the registry for corrupt or missing files and offer to install them from the CD

  Cesare 10:55 14 Oct 2006

I did SFC. Only one possible corrupted file found which could not be replaced from the Win 98 disk as it kept saying that D:\ is not accessable. The device is not ready. This file is Lmouse16.dll which I presume regards the mouse function. Otherwise all is OK. Yesterday I tried win98fix and Registry Mechanic. I have tried all possible things that I know but still no joy.One improvement today It is now recognizing & plays Video CD. I was all the time trying data Cdrw disks which it still does not recognise.

  jakimo 11:42 14 Oct 2006

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?