Device Manager / USB ports

  paulb55 10:54 06 May 2007
Locked

Due to having to rearrange the room (wifes idea) the pc had to disconnected and resited. I had 2x4 usb ports connected to the pc, which also had 4 back and 2 front ports.I replaced the 2x4 ports with a 7 port hub. When the pc was eventually resited (dont ask - womens logic!!), i connected all the usb cables. Some devices such as the camera, ipod, printer, worked once connected - others such as the mobile phone, scanner, web cam could not find the right driver? I tried using the device manager to locate / update, this failed to resolve the problem. Can you assist. I thought (naively) that XP sp2 should be able to locate all drivers on your hard drive and match that to the device. Help!!

  xania 11:01 06 May 2007

Not necessarily. But I would have expected that, once installed, as you obviously have, juggling with the USB ports would not have made any differnence. I suspect that your failed devices are all on the same USB hub, and this could be the problem. Go into device manager and see if any have a yellow exclamation mark - if so, delete these and try a reboot. Also try the faulty devices in another port and see if this improves matters - you could have a fault hub - and try swapping cables around to see if that identifies any problems.

  MAJ 11:02 06 May 2007

I hope you're using a powered hub somewhere in there, paulb55, that's a lot of peripherals to be running without a powered hub.

  paulb55 17:20 06 May 2007

Thanks for the suggestions, the hub is powered and there is no exclaimation marks in device manager. Sorry i should have mentioned that i had checked them before hand.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?