Device driver not found MSCD001

  Catastrophe 13:35 21 Oct 2006

I am trying to do a fresh install on formatted disk which is recognised on boot. CD/DVD drives also recognised (I have tried three different ones.

On startup the driver is not written to disk, and I get:

Device driver not found MSCD001 so I cannot proceed to load OS.

I have tried 3 IDE cables with HDD and DVD on same and different cables. All correctly jumpered. I have also tried two different startup disks - one made today specially.

Has anyone any ideas please?

  anskyber 13:46 21 Oct 2006

It could be a corruption rather than connection click here

  Catastrophe 14:33 21 Oct 2006

Yes, I thought connections unlikely as both drives recognised and 3 IDE cables used.

However, corruption of startup disk(s) is unlikely as I made one today and both function perfectly in other respects. Also both made on different PCs but from same Win98SE disk.

  Catastrophe 07:12 22 Oct 2006

Any ideas please?

  Fruit Bat /\0/\ 10:51 22 Oct 2006

IF "%config%"=="NOCD" GOTO QUIT
IF "%config%"=="HELP" GOTO HELP
LH %ramd%:\MSCDEX.EXE /D:mscd001 /L:%CDROM%

is in your Autoexec.bat file
and Config.sys file looks like

menuitem=CD, Start computer with CD-ROM support.
menuitem=NOCD, Start computer without CD-ROM support.
menuitem=HELP, View the Help file.

device=himem.sys /testmem:off
device=oakcdrom.sys /D:mscd001
device=btcdrom.sys /D:mscd001
device=aspicd.sys /D:mscd001

device=himem.sys /testmem:off

device=himem.sys /testmem:off

devicehigh=ramdrive.sys /E 2048
device=display.sys con=(ega,,1)
country=044,850,country.sys con cp prepare=((850) ega.cpi) con cp select=850 uk,,keyboard.sys

lastdrive being set to a low letter can some times cause your problem

  Catastrophe 13:23 22 Oct 2006

Fruit Bat

Thank you for that. I should have said that this is the only PC I have running 98SE. The others are XP Home or Pro.

My config.sys contains only:
device=C\windows\command\display.sys con=(ega,,1)
devicehigh=C:\windows\command\drvspace.sys /move

and my autoexec.bat only:

mode con codepage prepare= {{NO SPACE}}((850):\windows\command\ega.cpi)
mode con codepage select=850
keyb uk,,C:\windows\command\keyboard.sys

All against boxed which are all ticked.

  Fruit Bat /\0/\ 13:57 22 Oct 2006

There is nothing to run the CD drive on your formatted disk.

Does your version of 98 still work?

if so make yourself a rescue disk from your own operating system

or download a boot disk from click here

  Catastrophe 07:08 23 Oct 2006

Fruit Bat

Thank you for your interest. I have made a startup disk from another PC and this is what I have used. On starting up I get C: with so many MB free, formatted. I copied the A: to C: to see if it would boot from HDD but it would not. There is no E: (CD drive) just C: and D: RAM.

The auto and config are from the startup disk.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?