Devcon Issue.

  arminmckidd 15:28 22 Jun 2009

Yeah so i have this usb drive which has its own software, which i need to work as i use it almost daily. Now im getting various errors like, 'usb not recognised' and such. I tried a number of things to get them working. The traditional way, or uninstalling/reinstalling the software didnt work. I tried the device manager route of disabling the controller (device) because this usb in question comes up in COM Ports, modem and cd/dvd which is weird cos its not a cd or a dvd. Ok, so then i tried the "devcon" route, which is the alternative to device manager. i tried disabling the device and re-enabling but to no avail.
It came up with command errors such as, 'PID_1003' and 'MI_00' (this is part of a long name which is the usb device). The reason i want to disable it is i want the PC to not recognise the device at all, as if its the first ever time im using it.
What am i doing wrong and what command must i insert into cmd to disable the device? I already have the names of the devices i want to disable, just not the rest???

  Fruit Bat /\0/\ 16:07 22 Jun 2009

Disabling is no good you need to uninstall the device in device manager

Refresh USB Ports
Use Drive clean up to remove USB device drive info from the registry
click here
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  arminmckidd 16:34 22 Jun 2009

by the way, i am running vista sp2 and i tried your suggestion, which was to uninstall the usb devices. I tried this but all i get is the progress bar and thats it, nothing else happens. So uninstalling the usb controllers doesnt look good.
I will try the disk cleap up option though.
How would i do it through the 'devcon' route or is there another way?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

Camera tips to take better iPhone photos

Comment transformer un iPhone en borne Wi-Fi ?