Desperate - PIO mode

  Ian in Northampton 08:26 16 Jul 2010

I started a thread on this a little while back and, while everyone was very helpful, the problem isn't solved. The problem is both my DVD drivers are stuck in PIO mode. So far, I have tried everything I could find - uninstalling the secondary IDE channel, running a .vbs script, toggling the settings, changing registry values and goodness knows what - but to no avail. In desperation, I bought two new drives to see if they were the problem - but they're not. The problem persists.
I'm hoping that a new pair of eyes will chance upon this thread and have some different ideas...
I'm also starting to believe that even a clean install of XP won't fix it - although I may even try that.

  Chris_Byers 09:30 16 Jul 2010

Things to do\check:

1. Uninstall the drive and all (not just the secondary) IDE channels the device is connected to and reboot. Windows will reinstall the IDE channels correctly.

2. Install the correct and latest motherboard drivers.

3. Ensure you are using an 80 pin IDE cable, not the older 40 pin type.

4. Check the master\slave jumper is set correctly.

5. If possible try and get the drive on it's own seperate IDE connection amd not sharing a cable.

  Proclaimer 09:48 16 Jul 2010

Keep the DVD Drives on Separate Channels and check your BIOS Settings for UDMA Modes or UDMA-3.

If your BIOS IDE Settings are listed, check the IDE autodetection as this setting can set this (PIO) value automatically.

Check for a Newer BIOS Revision for the Motherboard and Flash the BIOS.

Check the Drive Manufacturers site for a Firmware update for the Drives.

Look in the Device Manager (right click the My Computer Icon) and check the IDE Channel Properties. Use the Advanced Settings in Properties View and check what mode the device is in. You may be able to select DMA mode from there.

If you cannot select DMA mode from there, remove the DVD Device from the Device Manager, reboot the PC, let it auto detect the 'new' device and repeat the above step as this may let you see the DMA mode again.

  Ian in Northampton 12:05 16 Jul 2010

Chris/Proclaimer, many thanks. I guess an important piece of information I left out of my original post was that there was once a time when this problem didn’t exist. Unfortunately, I don’t often use my DVD drives, so, when I noticed the problem, it was impossible to work out what might have changed (e.g. installing new software) that might have caused the problem.

For that reason, I’m not sure that checking the drive settings is worthwhile (although I know they’re set right – the drive at the end of the cable is set to master, the one part way along the cable is set to slave (or secondary or whatever)). For the same reason, while I understand the advantages of the 80 pin cable, it was working fine with the existing 40-pin cable. That said: do you think a problem might have developed in the cable that could cause this – in which case, I guess I could try replacing the cable.

Because it was once working properly, I’m not sure how upgrading the motherboard drivers would work, although last time I reinstalled XP – which, inevitably, wasn’t that long ago – I would have downloaded the latest drivers. I can’t think a BIOS update would help – again, because it once worked – and anyway, while there are many things I’ll try, flashing the BIOS isn’t one of them. Similarly, the two drives have always been on the same channel.

The drives I have installed now 0- in my last desperate attempt to fix the problem – are flashed to the latest firmware version.

Yup, I’ve checked the advanced settings in Device Manager and, while the option shows ‘use DMA where possible’, both drives remain stuck in PIO mode.

However, Proclaimer, your suggestion about checking the BIOS settings for the IDE autodetection rings a bell with something I think I’ve seen somewhere else, and would sound like a very logical choice – except that I can’t understand how the BIOS settings for IDE would have got changed. However, I plan to try that – what can I lose?

Many thanks to both of you. I hope it doesn’t sound like I’m rejecting your excellent suggestions out of hand: they’d make perfect sense if the drives had always been stuck in POIO mode. The fact that this is s fault that’s developed makes me be slightly sceptical about some of them, though.

I guess the acid test of whether it’s something to do with the motherboard, the BIOS or the IDE cable would be a fresh install…

I’ll let you know how I get on with changing the BIOS settings.

  Ian in Northampton 12:44 16 Jul 2010

Well, I checked everything I could find in the BIOS relating to the IDE channels, and everything I could find was set to 'auto'. Is there anything I could have missed?

  Chris_Byers 14:01 16 Jul 2010

I would use an 80 pin cable if you are using a 40 pin currently.
What an 80 pin dows is 'pair' the wires inside it to allow greater data throughput and reslience that you simply don't get with a 40 pin. THis will casue 'random' problems such as this and may be the reason that Windows will not allow you to have a better connection setting, becasue it has tested the connection and only found lower data rates available.

  Ian in Northampton 14:26 16 Jul 2010

Chris: at £3 a pop, that's got to be worth trying. I'll let you know. (Again, it doesn't 100% stack up. The theory is that Windows monitors an IDE channel and, once it's encountered 'n' errors (I think it's ~6) then it marks the channel as unreliable and restricts it to PIO mode. However, my understanding is that that becomes a registry entry, and should be capable of being changed/reset. I haven't managed to do that yet, though...)

  T0SH 14:54 16 Jul 2010

If your problem is indeed being caused by DMA errors, you can easily verify this by setting the mode as "PIO only" then rebooting, if you then change it back to "DMA if available", a scan for hardware changes in device manager should reset it back to a DMA mode for a short while , otherwise it is a MB chipset or maybe a driver issue

Cheers HC

  Ian in Northampton 15:29 16 Jul 2010

Tosh, thanks. Tried that - didn't work... :-(

  Proclaimer 18:54 16 Jul 2010

I would still strongly recommend you remove the device from the list in Device Manager and let it auto detect.

Windows will attempt to use DMA Modes but if it fails to register DMA modes (insert number I can't recall here) it will then lock the device into PIO Mode.

Removing the device and letting it re detect the device resets the forgotten number above :) Apparently it is a 'safety feature' in Windows.

  Ian in Northampton 19:05 16 Jul 2010

Thanks Proclaimer. What's weird is that I have just installed two new DVD drives in an attempt to fix the problem. Windows recognised them correctly and installed them - yet they too are stuck in PIO mode, and I've tried all the previous 'stuff' on them too..

But I'm happy to try what you're suggesting. Just to make sure I understand. I've uninstalled the IDE Secondary channel and let Windows redetect it on reboot - but you're suggesting I uninstall the physical devices in Device Manager?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?