Dell Latitude Laptop - CD drive recognition

  GeoffR 17:22 27 Nov 2006

I cannot get the Latitude to recognise the "D" drive (CD). It recognises A and C but not D. I have run a program PC Config which shows information about the computer, including all hardware and that says that there is no CD Rom fitted. I have tried various avenues but still come up with "no drive"

Geoff Richards

  Fruit Bat /\0/\ 19:09 27 Nov 2006

Enter the BIOS (setup) and check that the IDE controllers are enabled.
Check the drive is seen by the BIOS

  skidzy 19:13 27 Nov 2006

Any Error Codes ?

Is it showing in MY Computer ?

Missing cd/dvd drives can be normally associated with the removal of burning software such as Nero/Roxio etc.

Try the below link first,if still no luck follow the Procedure of removing the upper and lower filters.

click here

If you have further any error codes,please post them.

Restore Missing CD/Dvd Drives

Missing cd/dvd drive
If it is showing an error code, 10, 39, etc., delete the drive.

Then follow these directions for clearing the Upper/Lower Filters: (might want to print this out)

1. Click on Start --> Run --> and type in 'regedit' followed by the enter key
2. Expand the "HKEY_LOCAL_MACHINE" key (looks like a folder) by double clicking it (or
3. clicking the "+" next to it.)
4. Expand the "SYSTEM" Key
5. Expand the "CurrentControlSet" Key
6. Expand the "Control" Key
7. Expand the "Class" Key
8. Please look for a key containing the following string of letter and numbers:
9. High light this key by left clicking once on it
10. On the right hand side you are looking for "UpperFilters" and "LowerFilters" under the "Name" column, once you find these please delete them by right clicking on them and choosing "delete"
11. Please exit the registry by clicking on the "X" in the top right hand corner of the screen

Reboot your computer

  jjss 20:21 27 Nov 2006

This might seem a daft question but how old is your Latitude?

The old ones have an interchangeable floppy drive cartridge/module and cd drive cartridge/module(I still use one) When I've had a similar problem I've removed the cartridge/module and made sure that the pins are clean.

Enter Bios Setup and make sure that on Page1 that the module bay has CD-Rom as its option. Its easy to forget to change this if you've had your floppy drive cartridge for some time.

(if you have'nt got a modular drive bay type Latitude then this won't make much sense but it was just a though)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?