Dead Compaq Presario C310EA

  Squirrel1 10:31 30 Oct 2008

I have been given a Compaq Presario C310EA with the folowing problems:

When plugged into the mains, the chaging light flashes but the unit will not power-up or charge the battery.

If the battery is placed into another C310EA, charged-up and then connected to the 'faulty' C310EA, the copmuter will turn on.

Does anyone have any ideas?

I have tried another power supply and battery on the affected computer, but it is still the same.

  Taff™ 10:40 30 Oct 2008

Clearly a problem on the power/charging circuit board. It may be a loose connector socket - is there any play in the socket? You could try removing the battery and power supply then hold the power button for about 30 seconds. Plug in the power supply only and try a boot. This sometimes cures a problem. If that doesn`t work I suggest you find a local laptop repair specialist and ask for a quote.

  Taff™ 10:57 30 Oct 2008

This makes interesting reading. click here Do the symptoms match?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?