D:/is not accessible the device is not ready

  JOHN232 19:55 25 Aug 2005
Locked

Whenever I try using the CD Rom(using windows 98) I simply get this error messgage. Has anyone any suggestions? Pse keep it simple!!!!!

I've checked the Device Manager and it tells me that the device is working ok.
Music CD's bring up the same error message.
The drive has worked perfectly for a few years, but has suddenly developed this fault.

  Fruit Bat /\0/\ 20:01 25 Aug 2005

In device manager select the IDE channel the drive is plugged into (usually IDE2) right click and select uninstall.

Scan for hardware changes (Add new hardware) and reinstall the IDE channel.

If this doesn't cure the problem then the Drive laser is probably kaput. £20-30 for a DVD rewriter to replace your old CD rom.

  JOHN232 20:19 25 Aug 2005

I've gone into Device Manager and I've selected the 'Secondary IDE controller (dual fifo)'
It doesn't seem to give me the option of 'uninstalling', but I can 'remove'. It then gives me this warning.....
This device is part of a multi-function device and cannot be removed independently.
To remove this devive, select and remove the multi-function parent.

Parent Device.
Intel182371AB/EB PC1 Bus Manager IDE Controller.

Am I in the right place???? And what should my next step be??

  Fruit Bat /\0/\ 21:33 25 Aug 2005

Yes you can remove the parent device but as I said before its looking like a duff CD player.

One simply check is remove covers and check IDE cable is fully inserted but doubt if it is this as says working ok in device manager.

Can you borrw another oe to try?

  JOHN232 22:31 25 Aug 2005

Yes, I've got one that I can try......thanks for your advice....

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

See the work of famous artists playing with toys

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?