Cyberlink Power DVD

  kurd70 23:08 31 May 2003


A friend got a pc a few months ago and only recently tried his dvd player. Whenever a dvd which works fine on my pc is put into his pc the follwing error occurs will trying Cyberlink. 'A disc with a unsupported format in Drive D'
I have tried going back as far as system restore will allow me and the dvd error still occurs.
We dont know if the Cyberlink worked on the day he bought as he only tried it recently. I am reluctent to try The factory restore disk at this moment. Does anyone know how to get this cyberlink power dvd to work. If i put the dvd in and not select Cyberlink nothing happens. This problem is with xp.

Kind Regards


  TBH1 23:35 31 May 2003

I don't think the restore will sort it out, probably needs a fine 'tweek' or two . I run this program, but on 98se and if I recall, I had trouble with this when I first had it, 3 years ago, but cannot remember what I did to resolve it. Spooky enough I have had to rebuild my system over the last 2 weeks and its worked without original 'tweeks'.
Don't restore, hang on here for someone to sort you out.

  Beas-Knees 23:39 31 May 2003

Like TBH 1 says i wouldn't use restore disk as i don't think it will sort your problem, why not uninstall cyberlink power DVD and then install again,worth a try i think.

  TBH1 23:51 31 May 2003

thats a good call - -

  kurd70 02:42 01 Jun 2003

Cyberlink was installed on the pc when it was bought and no cyberlink disk came with the pc. Unfortunatly i cant uninstall and install

  Kryten 09:22 01 Jun 2003

Have you tried the computer manufactures telephone support. This could be a problem with the system setup and they may already know a way of correcting it. This sort of problem was happening on some time computers a few years ago, but was stopping the disk from playing because of problems with the region code not being correct with no way of changing it. This took a registry tweak to get that correct.

  rickf 09:38 01 Jun 2003

If you have a support disc from the manufacturer the Power DVD file should be in there. Explore the files obn disc and if its there you can then uninstall and reinstall from the file on disc.

  BeeWee 10:50 01 Jun 2003

go to the cyberlink website and d/l the patch for worked for me!

  Ellie3009 14:13 01 Jun 2003

My mums pc is a multivision, and also came with Cyberlink Power DVD, without a disk...

However!! The setup files are in a partition on the Hard Drive with all the windows setup stuff...
Try doing a search in all drives/folders and see for the words "cyberlink" or "DVD" and see if you can hunt down the setup files. Then you should be able to uninstall and re-install power dvd.

Although it's also a good idea to check for the patch or updates as Beewee said, as I had a similar problem and it turned out I was missing codecs.

  antoni34 14:34 01 Jun 2003

Check if there any patches out there ----
I say this because I am running an Athlon 2400 with a Pioneer A105 DVD/RW and had to download the latest patch 2 get it 2 work

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review

How to draw a mandala

iPhone X review

Les meilleures enceintes Bluetooth à moins de 150 euros