Crossover cable with XP problems

  Vardiss 10:39 15 Jan 2006
Locked

I'm trying to use a crossover cable to connect a laptop running Win XP home with a desktop running Win XP Pro. Neither are connected to the internet.

I ran the networking wizard and both are in the same workgroup. When they are both on I get the message on both that they are connected to the network at 100 Mbps.

I had to hardwire the IP addresses to get them to work. The laptop is 1.1.1.2 and the desktop (XP Pro) is 1.1.1.3. The mask is the one chosen by XP, i.e. 255.0.0.0 although I also tried 255.255.255.0

I left DNA and WINS blank.

I can ping the desktop from the laptop but when I ping from the desktop it times out. Neither computer can see the other in Network Neighborhood.

Any suggestions about what I have done wrong?

Thanks,

Vardiss

  PaulB2005 11:50 15 Jan 2006

Got an firewalls running?

Have you run the Home Network Wizard in the Control Panel? That should detect and set up most settings for you. Even if not prompted to do so, reboot after you run it, as i find that sometimes settings don't take effect until after a reboot

  mgmcc 12:12 15 Jan 2006

You cannot just make up IP addresses such as 1.1.1.2, your network must use one of the address ranges reserved for use in Local Area Networks.

Use addresses such as:

192.168.0.1 and 192.168.0.2 with Subnet Mask 255.255.255.0

or

10.0.0.1 and 10.0.0.2 with Subnet Mask 255.0.0.0

as these are both from Local Area Network ranges.

  Taran 12:13 15 Jan 2006

If you're comfortable manually setting the IP information on each machine (and you seem to be from your post) then try this:

Desktop:

192.168.1.1

Laptop:
192.168.1.2

Both get a subnet mask of 255.255.255.0 which will be auto-filled by the operating system when you manually assign each machine IP address.

You do this by browsing the TCP/IP properties of each network card and manually setting the options you want to use.

Finally and on each machnie, open your Control Panel, double click on the System icon, click once on the Computer Name tab and make absolutely certain that each computer has a different name (laptop and desktop for example) and that they are both on the same workgroup - MSHOME or WORKGROUP are the two most commonly used.

Restart each PC (not normally necessary but it sometimes helps) and then your last stage is to set up a shared folder on each computer. Right click on any folder you want to share (I usually make a folder called NetworkShare in My Documents and use that) and on the Sharing and Security option follow the prompts to share that folder.

Give it a minute or so then see if you can ping in both directions. If you can, see if you can explore the shared folder on the other machine using My Network Places in Windows Explorer.

The network wizard in Windows tends to get things right or spectacularly wrong and I dislike relying on it. If you use the settings I've given you above and still get no further forward we can start looking elsewhere.

  Taran 12:14 15 Jan 2006

Two people typing in the same thing at the same time...

;o)

  Vardiss 16:22 18 Jan 2006

Hmph. I tried both of the IP addresses and it still doesn't work: I can ping the desktop from the laptop but not vice versa.

I disabled the Firewall on the laptop running XP Home but I can't find a place to disable the Firewall on the desktop running XP Pro. It may be because neither of these is connected to the internet, nor will they ever be.

Any other suggestions? I may be overlooking something basic.

Thanks,

Vardiss

  Taran 17:18 18 Jan 2006

Control Panel >> Windows Firewall

Or right click on your LAN connection icon in My Network Places, left click on Properties, left click on the Advanced tab and click on the firewall button. You can switch it on or off, or create rules to allow traffic through.

I know this sounds silly but have you tried turning the cable around so that the end that was in the laptop is now in the desktop and vice versa.

Shouldn't make any difference but you'd be surprised.

I always suspect hardware once a few basic settings have been applied.

Create a shared folder on the machine to can ping to and try to access it from the machine you can ping from.

See what happens.

  Vardiss 10:37 19 Jan 2006

I'm getting the message on the laptop:

MSHOME is not accessible . you might not have permission to use this network resource.

  mgmcc 13:44 19 Jan 2006

"MSHOME" is just a Workgroup name, although it is essential that you have both computers in the *SAME* Workgroup and I would suggest not using the default name, use a name of your own.

In order to access XP Professional over a network, you need to be logged into the "client" PC with a Username & Password which is identical to that used to log into XP Pro, or at least have a User Account set up in XP Pro with login details that match those of the "client" PC. More info at - click here

Also, open the Network Connections folder, right click the Local Area Connection and select Properties. Highlight "Internet protocol (TCP/IP)" and click the Properties button. Click the Advanced button and, in the next box, select the WINS tab. Select "Enable NetBIOS over TCP/IP" and click OK back through the boxes.

  Vardiss 17:22 30 Jan 2006

Thanks for the replies.

I tried the thing suggested: turning the cable around, turning off Firewall on both computers, enable NetBIOS, using a different workgroup name.

I read the article mentioned above. The client computer is running Win XP Home but it is not prompting to enter a username and password. I have it set up so that neither computer asks for one when they boot up: its the administrator account since I'm the only user.

Is it necessary to create an account for the Home XP computer on the XP Pro box although since I'm using Simple File Sharing?


Vardiss

  mgmcc 08:31 31 Jan 2006

Yes, XP Pro must recognise that the access over the network from the "client" is from a valid user, i.e. one that matches an Account already set up in XP pro.

What you should be able to do in the "client" PC is to "Map a network drive" which will let you "Connect using a different user name". This can then match the login details for XP Pro.

In the menus in the client PC's My Network Places, go to "Tools > Map Network Drive".

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

What is ransomware and how do I protect my PC from Petya?

Microsoft Surface Studio – the artist's hands-on review

Original iPhone review

Comment mettre à jour Kodi ?