creative zen sleek firmware problem, not connected

  Superstylin 13:46 28 Jan 2007

i tried to update the firmware on my creative zen sleek mp3 player yesterday because my laptop wasn't recognising when it was connected.
unfortunately somethings gone wrong because now every time i switch on the mp3 player it just says firmware problem then goes to recovery mode. from there i tried to reinstall the firmware but straight away i'm told that the device isn't connected. when it is!
any ideas on what to do?

  Fateful Shadow 13:59 28 Jan 2007

I had EXACTLY the same problem on my Zen Touch about a week ago. I tried update the firmware but it failed halfway through and went into recovery mode.

Contact Creative. If you're still in the 12-month warranty period they can replace it for you. Be warned, though, as they like to go around in circles when they give you diagnostic tips. They should eventually authorise a replacement, however.

Just hope you've got your songs backed up somewhere =]

  Superstylin 14:01 28 Jan 2007

hi fateful, unfortunately my player isout of warranty by about a month, typically. did they give u any pearls of wisdom in the diagnostic tests that i might try? also, how did u get into contact with them?

  Fateful Shadow 14:05 28 Jan 2007

I hate it when that happens. I think they call it 'planned obscelesence' or something =P

Well, if you've got what I had, I guess you try to plug your MP3 player into your laptop via USB and then when you try to update the firmware it says the player is 'not connected?'

I got in contact via the Creative Website and going to the support section


  Superstylin 14:06 28 Jan 2007

yepthat's exactly what happens....have u sent urs off to be repaired?

  Fateful Shadow 14:10 28 Jan 2007

Yeah, I contacted them, and after many many e-mails they finally authorised a replacement. It's currently on it's way to wherever the repair centre is, and hopefully I should get it back soon.

It's the second or third time I've had a problem with it. Really annoying, seeing as it's the only 20GB player I could find for a half-decent price.

Does the computer recognise the player at all? Does it come up in the device manager?


  Superstylin 14:11 28 Jan 2007

it comes up but with a big yellow question mark next to it...i wish i'dleft the thing alone now!

  Fateful Shadow 14:14 28 Jan 2007

I know the feeling... I think that the original firmware works with Creative Mediasource(again, available from the creative website) but not WMP11 which is reallllly annoying =/

What you can try is to remove the MP3 player from the PC, uninstall/remove the item from the device manager, and then plug the player back in and see if it recognises it then =]

  Fateful Shadow 14:22 28 Jan 2007

Try this: click here={CEAE216D-8719-4C00-AC9F-03BC258F7B70},d=1130251443648,VARSET=ws:click here

I haven't been through all of the options but they might be able to help =]

  Fateful Shadow 14:23 28 Jan 2007

Bad link: click here and then scroll down to 'E-mail support' =]

  Superstylin 14:30 28 Jan 2007

tried to uninstall etc but still the same :S

i'll contact creative and see what they say.....i bet they say it'll cost me a shedload!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?