Creative speakers - dodgy connection

  Xnulian Rrudho 15:02 27 Sep 2010
Locked

Afternoon all. I've got a pair of Creative i-Trigue 2200 speakers which worked fine for years, but the power began cutting out intermittently a while ago, and it's got worse ever since - they now just don't work unfortunately.

Basically, at the point where the wire comes out of the plug, something must've come loose because the speakers only come on when I press the wire against the plug.

My technical knowledge is abysmal but I just wondered what your suggestions might be - I've read in other threads on here that Creative, unsurprisingly, don't do individual replacement parts.

Would this be absurdly difficult to fix by myself, or worth giving a go?

  gengiscant 15:12 27 Sep 2010

Which connection exactly are you talking about?

  HWJC 16:49 27 Sep 2010

I bet it's in the volume control thingy. We've had the same problem with Creative i-trigue speakers since we got it 3 years ago, but it hasn't packed in altogether yet.

My advice: buy a different make. I will. Recommendations gladly received.

  Xnulian Rrudho 17:46 27 Sep 2010

You reckon the problem's to do with the volume-controlling speaker itself? Interesting. Either way, I think I'm going to have to buy new ones aren't I.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?