Creative Connection Frustration!!

  warthog01 09:10 26 Mar 2009
Locked

I’m trying to in vain connect my Creative Zen Touch to my PC (XP Pro). When I plug into USB, the USB connection doesn’t register—instead, the Zen turns on and starts playing music. I think this is the root of the problem, but I’ve tried all the suggested fixes (at least the ones I’ve picked up so far). The Zen is recognised in Device Manager—with an exclamation point (driver not loaded). According to the Zen menu, firmware version 2.11.01 is loaded. I’ve downloaded the firmware file from the ‘net to attempt an upgrade, but it won’t load (probably because it won’t soft connect). I’ve reset the unit numerous times but I’m just about out of ideas. Is there another driver I’m missing and if so, where can I access it? Other than that, has anyone out there had a similar experience?

Thanks

  ^wave^ 09:26 26 Mar 2009

you are not the only one with probs most seem to be driver issues try this
click here
look at second page

  Graphicool1 09:39 26 Mar 2009

click here

Firmware
Creative Zen Touch PlaysForSure Firmware 2.11.01
Filesize : 2.46 MB

To install this firmware update:
1 - Download the ZenTouchP4S_PCFW_LB_2_11_01.exe file into your local hard disk.
2 - Connect your player to your computer.
3 - Double-click the firmware update file and follow the instructions on the screen.

While updating your player's firmware, you may be informed that an application is preventing the firmware update. Should this occur,
1 - Start Creative MediaSource.
2 - On the menu bar, click Tools -> Settings.
3 - Click the Detector tab.
4 - Click the Enable Detector checkbox to uncheck it.
5 - Restart your computer.
6 -Try updating the firmware again.

  Graphicool1 09:44 26 Mar 2009

These will...
click here

  warthog01 10:10 27 Mar 2009

Thanks, Graphicool

I've tried a dozen different fixes (from a dozen different forums) without success--I sent the support request email off this morning. Don't know how responsive Creative is to problems like this, but I'm completely out of ideas.

I tried the driver installation you suggested but got an error message telling me that "a service installation section in this INF is invalid." I don't really know what that means, but it didn't fix the problem.

Thanks for your help--fingers remain crossed!

  Graphicool1 17:11 01 Apr 2009

From your silence on this matter, do we take it the situation has been resolved?? Or hanging in the balance?

  ambra4 17:46 01 Apr 2009

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?