Could my PSU be the issue here...? any help appreciated :)

  Kasumione 23:52 31 Mar 2015
Locked

Hi there!

Thanks in advance for any help you can give to me..

My home built pc has been working perfectly for the past 2 years. Today the pc made a windows registry update and shortly after (say 5-10 mins) the pc closed down and would fire up for a split second only - afterwards.

I removed the PSU and used a paper clip to test the PSU and the fan started up, i connected the PSU to my hard drive, disc drive and they both started up without shutting down. When I connected it to my motherboard the lights of the board light up, but when I power on the motherboard it starts for a split second, shuts down and then will not power on at all afterwards unless I leave it for a 30 seconds in which it repeats the same process.

Could this be a bad power supply unit although it did seem to work well when powering disc and hard driveindependently. Motherboard has not been moved or bashed around, was brought brand new, Asus deluxe z77.

Also to mention that the heat sink fan spins and cuts out with the rest of the equipment on powering up. There is very little dust in the heat sink fan..

I have also removed the ram and tried to boot the mother board and cpu independently with the same result..

Confused, would be a shame if motherboard was faulty as it was new, undamaged and could not see why there would be a problem from nothing happening to it.

PSU is a corsair CX 430 i7 3770k processor 16gb corsair vengeance ram Velociraptor harddrive Samsung disc drive

Thank you as any help and advice is appreciated !

  onthelimit1 08:41 01 Apr 2015

I would be tempted to try a new PSU. It may well be that the additional load when mobo plugged is enough for the PSU to fail. If still the same, then probably the mobo.

  bumpkin 09:46 01 Apr 2015

Something is tripping the PSU which then re-sets itself hence the 30 sec delay. Probably it is failing but worth checking for a damged USB port first as this can cause it.

  onthelimit1 11:07 01 Apr 2015

Good thinking bumpkin - I've had that problem with front ports a couple of times over the years and had forgotten about it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?