corrupt hard drive?

  cdb 22:01 10 Feb 2007
Locked

I installed a new hard drive over Xmas and today when I went to turn my pc on it gives the initial beep and I can enter the set up options, by pressing the del key, after which it gives the list of pci devices screen (IRQs and so on) then some letters of text disappear and the computer hangs.

I swapped it for my origional hard drive and the pc works OK.

How do I find out what's wrong with the new hard drive and how can I sort it out or am I going to have to get another new hard drive?

(windows xp sp2, athalon 1800+)

Thank you for any help.

  ArrGee 22:53 10 Feb 2007

Make sure the jumpers on the hard drive are set to slave drive. There should be a label on the drive to show you the correct settings.

  cdb 22:55 10 Feb 2007

The hard drive was fitted and running OK for the last 6 weeks as the new master drive. It now hangs after the POST screen.

thanks anyway.

  ArrGee 23:00 10 Feb 2007

Try to install the drive as a secondary slave drive first. Check that the jumpers are in the correct position then (if you have access) backup any data from it.

See if it works ok as a slave.

  woodchip 23:01 10 Feb 2007

As above connect it as a Slave to the Old drive to get all your files of it, then rePartition and Format the drive. you will lose all when you do this on the drive

  cdb 23:04 10 Feb 2007

I've refitted it as a slave.

Is there no way to get it working again without reformatting it as I don't want to find I get the same problem in another 6 weeks and have to do another reformat ect.

  ArrGee 23:07 10 Feb 2007

Have you managed to move data from the slave to the main drive?

  cdb 23:13 10 Feb 2007

Not yet. I'll have to do it tomorrow

  lotvic 23:52 10 Feb 2007

if you go to the manufacturers site there will probably be a hard drive diagnostic prog that you can download and run.

you haven't said what make the hard drive is but it will probably be under warrenty and you will be able to get it replaced.

  cdb 12:11 11 Feb 2007

The hard drive is a 250G Hitachi international deskstar pata


I've copied most of the stuff I can to dvd's that way if anything goes wrong again I can load it straight from there.

I tried using my XP cd to ro a repair, but it gave me the recovery console and I didn't have a clue what to do. So I did a fixboot and the pc doesn't hang, but gives the message.

Windows can not start the following file may be missing or corrupt.
<windows root>\system32\hal.dll

Assuming that file is on the cd, how do I reinstall it?

  cdb 12:25 11 Feb 2007

Forgot to say. I can't access my own personal files on that drive. I must have set them to private. Is there anyway to unset this so I can copy them as well?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?