Correct ZA settings for ICS using ethernet

  Naeris 12:30 16 Jul 2006
Locked

Is anyone sharing an internet connection through an ethernet cable and also using Zone Alarm sucessfully?

Here's the set up:

Host pc connecting to broadband using adsl external modem (no hub extension).

Laptop networking sucessfully with host pc via a cat5e into on board LAN (host).

Laptop cannot connect to internet using host connection, although showing as connected just 404's all the time.

When I disable ZA and use windows firewall instead, the ICS works perfectly so it's obviously the settings in ZA that aren't right.

ZA is set up on both with the following settings:

HOST - has client ip secured for trusted and internet zone. Is on medium setting for internet zone.

CLIENT: has host ip secured for both zones also.

Don't want to use windows firewall, so has anyone else managed this sucessfully? (I read in 2005 that ade.h managed this but when I followed the steps suggested for IPCONFIG /ALL the screen came and went quicker than a teenage boy, so couldn't read it ha ha.

  FelixTCat 18:37 16 Jul 2006

Naeris,

Set up your network with the windows firewall. When the laptop is working to the internet, open a Command window (Windows\System32\cmd.exe)

In that window type ipconfig/all and press enter. Note the IP address of the laptop's ethernet port (something like 192.168.0.2) (or whichever network port is connected to the host pc).

Now enable ZA and disable the windows firewall. Open ZA's management console and open the Firewall tab. Click Add.

In the box, add either just the IP address of the laptop or (better) add a range of three or four addresses (eg 102.168.0.2 - 192.168.0.5)

OK your way out of ZA and test.

Also make sure that the laptop's firewall will enable you to access the Internet Connection Sharing address on the host pc (usually 192.168.0.1)

Best of luck

Felix

  mgmcc 19:31 16 Jul 2006

I would actually suggest adding the "Subnet" in Zone Alarm's "Trusted Zone" as that will allow access to all IP addresses from 192.168.0.1 to 192.168.0.254

Open Zone Alarm and select the Firewall tab at the left then the Zones tab at the top. Click the "Add" button and select "Subnet". Enter:

IP address - 192.168.0.0

Subnet Mask - 255.255.255.0

Description - {anything} but it needs an entry.

Click "OK" and, back in the main window, click "Apply".

In the Internet Connection Sharing *HOST* PC, the Internet Zone Security level must be reduced from High to Medium or ICS traffic will be blocked.

  Naeris 16:07 18 Jul 2006

mgmcc - will try that today.

felix - did you even read my post? lol

  FelixTCat 16:52 18 Jul 2006

Yes. What's your problem with it? ZA on your laptop must allow you to talk to your ICS connection on your pc and vice versa.

  ade.h 18:29 18 Jul 2006

I thought it was sound advice.

  Naeris 19:00 21 Jul 2006

I meant with regard to command ipconfig/ all as I mentioned in the end of my post that it came and went.

I also said that I had allowed both client and host on each ZA panels too.

Crossed wires I think! (no pun intended).

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires