Control Panel Icons missing...(again)

  m800afc 17:57 20 Nov 2008

Win XP Pro: SP3

My control panel icons have gone missing again. The "Don't Delete" value in the control panel registry is 0. I have tried setting it to 1, but that does not help. Last time it happened, it was resolved by a system restore, but as a system restore changes so many things I am very reluctant to do it again. Besides which, a system restore does not cure the problem, it just sidesteps it.
Any ideas chums?

  Kingfisher 18:05 20 Nov 2008

have a look here it might help click here=

good luck

  m800afc 18:38 20 Nov 2008

I have just tried Tweak UI. It did not help.

  BurrWalnut 18:44 20 Nov 2008

If some items are missing, click Start > Run, type regedit, press Enter and navigate to registry key
HKEY_CURRENT_USER\Control Panel\don’tload and delete items in the right pane that you want to see in Control Panel.

  m800afc 00:53 21 Nov 2008

I have navigated to "Don't Load". In the right pane there are just two items:
(Default) REG_SZ 0
ncpa.cpl REG_SZ No
There is nothing else.
Does this help?

  BurrWalnut 08:23 21 Nov 2008

That key is fairly typical. It may be malware, have you run your ‘anti’ programs?

The only other suggestion I can make is for Control Panel not appearing at all, I don’t think it is but you must look. Click Start > Run, type regedit, press Enter and navigate to registry key HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer.
In the right pane look for NoControlPanel, right-click it and make its value 0 (zero). If you are denied entry to regedit it’s a classic symptom of infection.

  m800afc 08:34 21 Nov 2008

I have navigated to:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer, and there is no key named NoControlPanel.
The nearest I can find that may (or may not) be relevant is:
There is a key:
NoDispCPL REG_DWORD 0x00000001 (1).

I have tried running sfc /scannow earlier this morning, but again, there is no change, even after a restart.

  BurrWalnut 09:16 21 Nov 2008

We‘re getting there, read this
click here

One word of warning, whenever you change a registry key, make sure you write down its previous value just in case things go wrong.

Also, I’ve just noticed you’re running XP Professional, which suggests you’ve been changing things via gpedit, am I correct?

  m800afc 10:37 21 Nov 2008

Thanks for the reply. The easy bit is that I have not knowingly used gpedit. Perhaps an application has changed things?

Now the strange bit. I always use the control panel in classic view, and as you know, the bulk of the icons are missing. I switched user to my partners account, without logging off, and the classic control panel opened with all the icons. I then switched to category view, and once again all icons and functions are present. I then switched back to my account, again without logging off, and in the classic control panel windows the icons were still missing. However, when I switched to category view, blow me down, all was present and correct. Furthermore, on inspecting the:
NoDispCPL REG_DWORD 0x00000001 (1)
Key, it was no longer there. Being a bear of very little brain I do not understand this.
The situation is now:
Self Partner
Classic View bad good
Category view good good

Clearly I can now use all functions, so the matter can be said to be resolved. I won't tick it just yet though as I would love to find out what the heck is going on, and if there is anything I should do to prevent it happening again.

Thank you very much in helping me to get my control panel functioning. It is much appreciated.

  m800afc 10:41 21 Nov 2008

Just to clarify, the table should read:

Classic View ....bad.....good
Category view....good....good

(I had not realised the tabs don't work on postings)

Thanks again.

  BurrWalnut 13:23 21 Nov 2008

I'm glad you're more or less back to normal.

You have to realise that you and your partner have different registry hives, e.g. different HKEY_CURRENT_USER\........

If registry keys are 'changing' mysteriously, I would look for a rogue program.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017