constant Screen jumping in windows 7 gaming and browsing

  sreuk72 22:02 22 Aug 2014
Locked

I have recently built a new pc, (4.2 o/c I5, gigabyte z87mobo, 8 gig corsair ram (all bought as a matched and tested bundle), I have a 650w psu and I bought a msi r9 280x twin frozr gaming edition gpu, A couple of weeks after installing the card I'm having constant screen jumps and flicker when doing pretty much anything on the pc, I have contacted the store I bought the gpu they said try a higher powered psu (havnt got one handy) ive contacted amd who said get the latest beta drivers, so I did a full clean install and installed the drivers and after 20mins boom same flicker, temps on gpu and cpu are under 50degrees so I dont think overheatings an issue but it dose seem to be worse after the pc has been on over 15mins, it can sit happily then it'll flash and jump maybe 6times in mad succession, non of this happens when I use my inbuilt intel hd4600 chip.

  Menzie 22:54 22 Aug 2014

600W is the recommended supply for that card but that is without over clocking. What model is your power supply?

Is there another PCIe slot on your motherboard to try the card in?

  sreuk72 23:13 22 Aug 2014

yes there is a spare slot on mobo its a gaming board and the psu is an ezcool 650w non modular.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?