Connection Healthy - but IE7 can't find pages

  Nick Hepher 22:05 15 Nov 2007
Locked

I have a Netgear DG834G ADSL router which provides a solid connection to the Internet (Ethernet connection to Desktop PC on BT Broadband). Outlook works OK, Skype works OK, XP and AVG update OK. Two laptops connected wirelessly work fine in all respects.

The only problem is that quite frequently, on the main Desktop I cannot access webpages via either IE7 or Firefox. I just get 'Server not found' or 'Cannot access' messages. Then suddenly after a period of anywhere between an hour and a day, I can suddenly access pages without problem. I have swapped AV software (from AVG to Kaspersky and back), disabled software firewalls, switched off and on again after 5 minutes, changed routers - I've even phoned BT Broadband helpline!

Nothing has got rid of the problem. Sudden restoration of the access occurs quite randomly. Sometimes after a lot of activity (emptying caches, temp folders etc.) sometimes it just happens!

One thing I can do, however, via both IE7 and Firefox, is access my work email address via Outlook Web Access.

As the laptops both behave faultlessly I must assume it is something in the Desktop - rather than router or line. However I am at a loss!

Does anyone have any ideas? I have tried 'Googling' the problem but it doesn't seem a common occurrence.

Any help would be much appreciated!

  mgmcc 22:19 15 Nov 2007

Try repairing the TCP/IP stack and Winsock which might just fix the problem.

Open a Command Prompt window ("Start > Run", type CMD and click OK).

To repair the TCP/IP stack, at the prompt, type...

netsh int ip reset resetlog.txt

...and press Enter

(note the spaces in the command line). The original prompt will reappear, exit the Command Prompt window and reboot the PC.

To reset Winsock entries, at the prompt, type...

netsh winsock reset catalog

...and press Enter

Exit the Command Prompt window and reboot the PC. (If running both repairs, reboot only after running the second command.)

  Nick Hepher 22:39 15 Nov 2007

Thanks for the suggestion. I have gone through the resets as suggested. I will now see how things go over the next 24 hours - I will feedback then.

  Nick Hepher 05:25 16 Nov 2007

Since doing the resets, I have been unable to access the web at vie - either via IE7 or Firefox. So it looks as if that wasn't the problem....

  Nick Hepher 08:27 18 Nov 2007

It seems my DNS client had somehow got disabled. Resetting it solved the problem. The mystery is how it happened! DNS Hijack? I'm not sure....

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?