Connect 2 PC's using ethernet card and crossover c

  STREETWORK 12:12 14 Aug 2006
Locked

Having problems:

I have connected 2 PC's (both win xp) using the installed and working ethernet cards.

PC-1 is connected to internet broadband and reports limited or no connectivity.

PC-2 is set up and reports no problems but cannot connect to internet using the host PC-1

I have run the setup wizard and followed it to the letter on both PC's.

I need to allow printer and file sharing, and this seems to be set up ok.

Questions:

1. How do I allow internet connection from PC-2?

2. How do I resolve the problem on PC-1

3. Have I missed something out?

You help will be appreciated

  rodriguez 12:27 14 Aug 2006

Really you should use a router if you want to share Internet access. The router plugs into your ADSL line and connects to PC-1 via USB. PC-2 then connects to the router with an Ethernet cable. Run the Network Setup Wizard on both computers and it should work ok. Most people say you need a crossover cable to connect the PC to a router, and the guy in Maplin gave me a crossover as well. But when i tried to connect it it wouldn't connect and the LAN light wouldn't even come on the router. So I took it back and swapped it for a straight cable and it worked. So this could also be one of the reasons you're gettin limited or no connectivity at the moment.

  STREETWORK 13:05 14 Aug 2006

Have no funds for a router at this time, just want to connect the two pc's and use internet on PC-2. There must be something I missed

  FelixTCat 13:09 14 Aug 2006

STREETWORK,

You haven't told us how you are trying to connect to the web on PC-1 - if you can't do it on PC-1 ("PC-1 is connected to internet broadband and reports limited or no connectivity.") you are hardly going to be able to do it from PC-2 through PC-1.

Your connection between PC-1 and PC-2 seems OK since you can share files.

Regards,

Felix

  mgmcc 13:16 14 Aug 2006

It sounds as though you haven't enabled "Internet Connection Sharing" in your Host PC and, in the absence of a DHCP server from which to get IP addresses, Windows has allocated "169.254" addresses to the two network adapters. This will normally let you run File/Printer sharing, but won't support internet access.

To enable “Internet Connection Sharing” in Windows XP, open the Network Connections folder, right click the actual internet connection (modem connection), select Properties and then the Advanced tab. Tick the box “Allow other network users to connect through this computer’s Internet connection”.

When you enable "Internet Connection Sharing" on the Internet connection, it automatically configures the network adapter used for your "private network connection" with the IP address 192.168.0.1 and subnet mask 255.255.255.0. If you have more than one adapter available for this purpose, e.g. both a "Local Area Connection" and a "Wireless Network Connection", you will have a drop down list from which to select the appropriate adapter. The "Client" PC's local Area Connection should be set to get its IP address automatically, which it does by DHCP from the "Host" PC. Also, if you run the Zone Alarm firewall in your "Host" PC, the Internet Zone Security level must be reduced from High to Medium or "ICS" traffic will be blocked.

  STREETWORK 13:37 14 Aug 2006

Getting there, thanks for advice so far.

Zone alarm is set to medium (had this done already).

I have enabled Internet Connection Sharing on PC-1, which is connected to Broadband ADSL. This has solved the connection between computers and now they both report 'Connected'..yeehaaa!!!!

I now need to get PC-2 sorted to connect to the internet through PC-1. Do I need to set up anything on PC-2 to do this?, ie a new account or do I use the ISP username and password from PC-1?

  mgmcc 14:10 14 Aug 2006

You don't do anything in PC2. If PC1 is online, PC2 should also have internet access via the network - it *DOESN'T* need to establish a separate connection to the ISP.

You will have to configure Zone Alarm though. Open Z.A. and select the Firewall tab at the left and then the Zones tab at the top. Click the "Add" button and select "Subnet". Enter:

IP address - 192.168.0.0

Subnet Mask - 255.255.255.0

Description - {anything} but it needs an entry.

Click "OK" and then, back in the main window, click "Apply".

  STREETWORK 14:35 14 Aug 2006

Thanks mgmcc,

This I have now done, but PC-2 will not connect to internet. how would I establish a separate connection? yeah, none techy here...

  ade.h 15:05 14 Aug 2006

You have told PC2 where/how to get a WAN connection, yes? The simplest way in this instance is to run the New Connection wizard and choose the option to get WAN access through a gateway (ie. PC1).

  STREETWORK 15:47 14 Aug 2006

Not sure how this is done, seem to get confused with the wizard, can you list the things to do please

  STREETWORK 18:18 14 Aug 2006

After rebooting both computers they identified each other through the crossover cable connection and I was also able to connect to the internet from both PC's.

Today I have learnt something - 'The obvious is not always that obvious'

I thank you all for your kind help, and now how to print via the network...

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?