Computer Won't Recognise my Memory Stick

  Dirtymcb 13:52 25 Jul 2009

Hello. I was wondering if someone could help me.

My PC won't recognise my USB memory stick when I enter it into any of the available USB slots. When I first got the stick, when it was plugged in, it would automatically open a window and I would be able to access the files saved on the memory stick. Now when I enter the stick, nothing happens. It doesn't even show as a removable device under 'My Computer.'

I've tried the memory stick in another computer and it works fine, likewise when I plug in other USB devices into my computer, they work too.

If anyone could be of any assistance it would be much appreciated!

  Fruit Bat /\0/\ 14:10 25 Jul 2009

Refresh USB Ports
Use Drive clean up to remove USB device drive info from the registry
click here
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  Dirtymcb 21:31 25 Jul 2009

Thanks fruit bat, I've tried that but unfortunately no luck.

I've tried another memory stick from another manufacturer but that doesn't seem to work either.

  Bris 20:03 27 Jul 2009

Go into control panel and then disk management after inserting the stick and see if it appears there. If it does but with a drive letter of * then assign it a drive letter then explorer should see it. The problem may be that for some reason the OS is unable to assign a drive letter because they are all used up or that you have used something like Tweakui to limit the drive letters available.

  Dirtymcb 02:00 28 Jul 2009

Ok if I go to Device manager and insert the stick, under disk drives 'USB Flash Memory USB Device' comes up, so the computer seems to be recognising the device.

I've just uninstalled the drivers and reinstalled, but still no luck. Does anyone know how I can access the device?

With regards to your post Bris, I can't seem to find anything under Disk Management...although I'm not too sure where I should be looking.

  Bris 19:45 28 Jul 2009

For VISTA its in Control panel/administrative tools/computer management/disk management.
I believe the reason that Windows doesnt see it is because as far as your PC is concerned it has been allocated a drive letter of (*)and once this happens it will refuse to recognise it until you assign a drive letter manually. This sometimes happens if you physically remove the drive before you have taken the option to remove it from the system first. The reason why another PC sees it is because that PC is able to allocate a drive letter for it and the reason why other devices work in the same USB port such as printers and scanners etc is because they are not drives and therefore the OS does not neeed to assign a drive letter to them. Hope this helps.

  Bris 19:49 28 Jul 2009

If you find it in disk management and it has a drive letter of * then right click on it and choose "change drive letters and paths" then you can either accept the one it chooses or choose one from the list yourself.

  Dirtymcb 20:25 28 Jul 2009

Thanks for the help Bris, but the memory stick doesn't show up in disk management.

  Bris 11:38 29 Jul 2009

Hi. What Fruit Bat and I have suggested usually cures 99% of Flash drive problems so you have an unusual one here. Its the type of issue where hands on is often the only way to sort it out, however, I have laid out a few things for you to consider that may help in sorting the problem. Unfortunatley I am away as from today so hope that someone else in the forum can pick this up.

When you plug in a flash drive for the first time into a specific port the OS will install the necessary drivers and update the registry so that the next time you plug the same drive into the same port it doesnt need to install the drivers again. If you plug the same drive into a different port then it will go through the same procedure of installing the drivers and so on for each port. So if when you plug in the drive it doesnt load the drivers (it will tell you if its loading drivers)then it already has an entry in the registry so knows about the drive. Thats where Fruit Bats solution comes in i.e. flushing the registry so that all info relating to the drive is removed and thus forcing it to re install the drivers. If it recognises the drive but refuses to access it thats when my suggestion comes in of checking the drive letter as it will refuse to do anything with a drive that has a drive letter of * (unallocated).

Go into Device manager and open the Portable Devices leg then open the Universal Serial Bus Controllers leg THEN plug in the drive and you should then see "USB Disk 2.0" appear in the Portable devices leg.
In the USB Controllers leg a "USB Mass Storage Device" should appear.

In Disk Management you should see "UDISK 2.0".

Also go into Event Viewer and expand the Custom Views/Administrative Events leg and look for any related messages, likewise with the Windows log/ System leg.

Good luck with it.

  Bris 11:41 29 Jul 2009

Just another thought. As you have tried another drive and that doesnt work either then it suggests possibly that it is unable to load the drivers because they are either missing or corrupt?

  Stuartli 11:46 29 Jul 2009

>>to assign a drive letter because they are all used up>>

All 26 of them?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?