Computer won't read external hard drive

  User-88C275E8-EB03-4BC4-A4366AF1623A2182 18:49 04 Feb 2011

I've dismantled an old PC and taken out the 500gb SATA HDD and fitted it into a Smart Drive enclosure to use it as a back up for my laptop.

Everything is connected and powers up and the laptop identifies the external drive as a mass storage USB device and loads a driver. I can see the device shown in Devices and Printers. However, the laptop cannot see any of the files which are currently on the disk and which I want to transfer to the laptop,it shows the volumes as empty. I've tried a driver update but that's not the problem.

I'd be grateful for any thoughts

  mooly 18:54 04 Feb 2011

Can you see the device in "computer".

As it's a laptop, one thought is that the USB port may not be able to supply sufficient power, although if the device is recognised i wouldn't have thought that to be an issue. Just mentioned that because a new portable HDD I have has a "spare" USB plug on it's lead to double up using two ports if needed.

  mooly 18:56 04 Feb 2011

One other thing... would using a Linux CD enable you to see the contents in the way that Acronis does by running outside of windows as it were.

  Fruit Bat /\0/\ 19:35 04 Feb 2011

Right click select properties
does the drive show as fully unused space?

Thanks for the replies

mooly: the drive does not show in My Computer, only in printers & devices. tried running it through a powered USB hub but no joy.

don't know about Linux CD I'm afraid.

fruit bat: Drive shows has nothing in the volumes. Because it doesn't show on My Computer i can't get that property dialogue box to show free space.

I just plugged it into my iMac to see what happened. Mac cannot read any of the files but does recognise the disk as 500g and is happy to format it. Not much help until I get the data off which is all wav files

  BRYNIT 22:28 04 Feb 2011

Go into disk management and see if a drive letter has been assigned. If not assign a letter.

  mooly 08:15 05 Feb 2011

Using Live Linux Disc,
click here

Maybe there is a problem with the MBR etc that prevents your laptop "seeing" the drive as something it can use, but I'm just guessing.

binty: thanks for that. Disk Manager just shows drive as "Disk 1 Dynamic Invalid" Won't let me allocate letter. Only option i have is to convert Dynamic to Basic which will aipe the disk

Sorry Brynit...typo!

  peugeot man 12:25 05 Feb 2011

Interesting topic Hellfire, I have been trying to solve exactly the same problem. I am trying to read a Seagate and a WD using a powered USB caddy.

Windows detects the drives being connected, device manager shows them as working ok but they do not appear in "my computer" and when looking at the properties in device manager the volume is blank.

The results are the same using Windows 7 or XP Pro.

Any suggestions welcome, if I ever solve it I'll post the answer here.

Peugeot Man: It's a mystery. In Disk manager (Windows 7) it reads as invalid and it won't let me activate it.

Just to check I'm not going bonkers I've stuck the disk back into the shell of my old PC, which runs X) and it all works perfectly.

I have two of thses 500gb disks, neither of which could be read by the laptop. However, the other disk had no crucial data on it and my iMac was happy to see it and format works fine on the Mac as an external

Once I get the data off this other disk I'll use it on the imac but I do need the data. I will give mooly's linux suggestion a go.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Lightwell software lets you create mobile apps without using code

Best value Mac: Which is the best £1249 Mac to buy

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?