computer wont power up :( Acer Aspire L100

  Haldi2008 20:49 08 Apr 2008

I have an Acer Aspire L100 Small form desktop which I was planning to upgrade from 1gb to 2gb memory. To check the memory type before buying I opened the case removed the memory and replaced it however when rebuilt I cannot get the unit to power up. There seems to be power to the unit as the LAN light flashes once (only once) when I plug the power in. I cant seem to find whether there is a case open interlock anywhere that needs resetting or find very much information at all.

Please can someone help and just point out if I am being stupid.


  Fruit Bat /\0/\ 21:09 08 Apr 2008

Probably not got memory back in correctly - remove and refit.

Could also have disturbed connection to motherboard when removing mem - check all motherboard plugs.

  Haldi2008 21:15 08 Apr 2008

have removed nd refitted the memory checked all the plugs and all are securely fitted...

  Gordon999 13:45 09 Apr 2008

Hi Haldi,

I had a similar problem last year when upgrading my wife's laptop. She had 512MB ram I added anothet 1GB ram module but put them in in the wrong slots so when I tried to power up I got nothing. took them out changed them round and it worked fine. not sure if this is your problem.

Have you tried replacing the old module booting up to see if you get power..if so the new module may be you problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?