command window installation - how?

  [email protected] 22:27 18 May 2009

I need to try and run the installshield installation of silkypix through the command window.

Anyone know how?

"Running installshield as an administrator. An easy way to do this is to run installshield in an administrator command window. To do this, run cmd, and at the command prompt type "at (time) /interactive cmd.exe", where (time) is any time in the near future, expressed in 24 hours. At such time, a new command window will open, and an installation run from this window will have administrator priveleges.

  phono 22:58 18 May 2009

Not sure about the command window yet but is this of any help? click here

  hssutton 23:07 18 May 2009

Can't help, but puzzled why you don't just use the "Setup.exe", which works perfectly ok.

  phono 23:11 18 May 2009

I would recommend downloading the Windows Installer CleanUp Utility from click here click the download link, install and run, look for the Silkypix installation and select it, click remove and all installation traces of Silkypix should be removed from the registry.

Now try installing Silkypix through Windows again.

  phono 23:16 18 May 2009

"I need to try and run the installshield installation of silkypix through the command window."

Is this of any help? click here

  [email protected] 00:28 20 May 2009

hss, how exactly do I use "Setup.exe"

phono, in the cleanup util - for windows own installers?

I've tried safemode install and installshield scripting doesn't work (1607 error)


  brundle 00:31 20 May 2009

What error number are you seeing when you try the normal install? Link to your previous thread, for other contributors; click here

  [email protected] 09:40 20 May 2009

My basic problem is overcoming an apparent installshield issue with windows... error is...

"Install Wizard was interrupted before - Silkypix could be installed. System not modified.' try again later... aargghhh ;-)

Silkypix is a raw image convertor bundled with lumix cameras. It get's right to the end of the installation and then stops/interrupts...

I have a feeling the problem will be some annoying log file somewhere interfering... Perhaps I should try ccleaner??

Phono -my previous comment should have read... Is the Windows cleanup utility only for Windows own installers rather than 3rd party?

  brundle 11:14 20 May 2009

I assume you're using an Administrator account already, if you have no trouble installing other programs. Create a new administrator account, log into that, then try the installer. Very much the same thing as the command-prompt tip you've already asked about.
If you haven't actually managed to install the software the MS cleanup utility won't find anything to remove.

From phono's link; "You can use the utility to remove installation information for programs that were installed by using Windows Installer. Be aware that Windows Installer CleanUp Utility will not remove the actual program from your computer. However, it will remove the installation files so that you can start the installation, upgrade, or uninstall over"

1. Look in the event viewer for errors relating to the installer.

I would be looking at something like Filemon after that, but it takes some time to narrow down exactly what you want it to keep track of and how to interpret the results. click here

A brief guide; start Filemon while your PC is idle, right click entries that create floods of information and add them to the filter, when the "background noise" has been reduced to an acceptable minimum, start the installer and let it run through until the error occurs. Go into Filemon, stop monitoring, export the log file into notepad or Excel and look for Failed or Error entries - you could filter Filemon's output to show just those entries itself, which might be easier to check (there will be thousands of SUCCESS entries).

  brundle 11:18 20 May 2009

It might help to disconnect from the internet and disable your antivirus/antispyware program before installing too.

  [email protected] 13:23 20 May 2009

Thanks for the reply - much appreciated; it's very tempting to tear one's hair out over this kind of thing.

I am using an admin account and I've checked that it's listed in the local security policy - impersonating...etc. But creating another admin account definitely sounds worth a go.

I'll also give Filemon a try, see if it picks any specific installshield conflict up.

When I ran regedt32 (I think) I noticed there were 7 installshield drivers, but no option (AFAICS) to delete. Might there be a way to remove all traces of Installshield, download a new version from scratch and try this..? I'm just clutching at straws really.

AFAIA Acresso apparently own Installshield, but not the software being installed. Silkypix make the software and build the installation file, but are at the mercy of installshield/windows conflict. Panasonic burn it on a disk (?)... Windows goes its merry way. We're on our own. Sorry just a moan.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

This is what design agencies will look like in 2032

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache