Comm Port error codes

  User-9477D528-F91F-47D3-97547041A7F1743D 17:18 11 May 2007

This is my first time so I'm feeling my way!
I have downloaded update software to my PC to be transferred by null serial cable to my Humax PVR (Digital TV HDD Recorder). I run into trouble after everything is connected and attempt the transfer. The pc displays a list of 4 comm ports but whichever one I choose is blocked by an error code of either 2 or 5. Where can I find an explanation of these codes?

According to my hardware setup I only have one comm port and I only have one physical serial port on the back of my desktop case. Any help will be appreciated.

  Fruit Bat /\0/\ 18:35 11 May 2007

Code 2
Depending on which device is failing, you may see either of two different messages. This code means that the device loader (DevLoader) did not load a device. When this device is a Root Bus DevLoader (for example, ISAPNP, PCI, or BIOS), the following message is displayed

Windows could not load the driver for this device because the computer is reporting two <type> bus types. (Code 2)

Contact your computer manufacturer to get an updated BIOS for your computer.

Where <type> is ISAPNP, PCI, BIOS, EISA, or ACPI.

Solution button: None
When the device is not a root bus DevLoader, the following message is displayed

The <type> device loader(s) for this device could not load the device driver. (Code 2)

To fix this, click Update Driver to update the device driver.

Where <type> is the DevLoader such as FLOP, ESDI, SCSI, and so on.

Solution button: Update Driver
In addition to following the recommended solution, try removing the device from Device Manager, and then running the Add New Hardware wizard.

Code 5

The driver for this device requested a resource that Windows does not know how to handle. (Code 5)

To fix this, click Update Driver to update the driver for this device.

Solution button: Update Driver

This code indicates that there was a device failure due to the lack of an arbitrator. If a device requests a resource type for which there is no arbitrator, you receive this error code.

To resolve this problem, update the driver as suggested, or use Device Manager to remove the device and then run the Add New Hardware tool in Control Panel.

The physical port will be PORT 1
Check the serial port is Enabled in the BIOS

Then check you can see Comm port 1 in the device manager and there are no conflicts with other equipment.

Fruit Bat - thank you for your quick response.
I will print your response and mull it over, over the next few days.
I will let you know how I get on - thanks again.

Fruit Bat - as promised, an update.
Problem solved based on your suggestion re Code 5.
I accessed my BIOS and changed my Onboard Serial Port 1 from 3F8/IR4 to Auto. I made no other change. Subsequently the update of my Humax PVR proceeded smoothly. Thanks for your help.

My BIOS is an Phoenix Award dated 24 June 03 and due for an update, however the dire warning shown on the download website put me off the update as I obviously do not want to risk damaging my system. What is your experience of update the BIOS and am I being fainthearted? You comments appreciated please.

  Fruit Bat /\0/\ 17:26 21 May 2007

No your not being faint hearted

Only update if you really have to!

A failed BIOS update will render the motherboard and therefore the PC useless.

I wiped out a board trying to update a BIOS (gave me an excuse to up grade the PC but cost 200 quid for the privilidge) took two years to get the board to work again, by then it was obsolete.

Thanks for your response I shall mark this matter as satisfactorily resolved. I hadn't realised this helproom existed until I looked through an old PC Advisor in the dentists waiting room! Thanks and Good Luck.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires