Colour print problems - Epson Stylus 950

  PeterPaul 22:21 03 Apr 2003
Locked

I am using Adobe Photoshop elements to print digital photographs to an Epson Stylus 950 colour printer.

All printed output has a pronounced blue cast, and colours, especially wood browns are not rendered accurately.

I have tried colour management on every option - nothing affects the output. My cartridges have not run out. (My monitor is a Sony Multiscan 210ES.

Any ideas?

  Pesala 22:31 03 Apr 2003

I am not familiar with the Epson Photo printers, mine is a Stylus C80, but I also had serious colour problems. Some photos matched perfectly, whilst others with different predominant colours were way off. On my Printer Driver there is a check box for digital camera correction. In my case I solved the problems by experimenting with different options for Photoenhance Mode, which has different settings for people, nature, standard, and sepia.

You could also try these monitor tests to check your monitor calibration:

Monitor Tests: Display Calibration click here Monitor Response click here Screen Calibration click here (provided by Huggyg71)

  woodchip 22:46 03 Apr 2003

Just run a test page to check you are getting the correct colours. From Start Settings\printers right click on your printer choose properties then click print test page

  PeterPaul 00:26 04 Apr 2003

Thanks for the help - I have tried varying the settings - no change, unfortunately.

I think I may have a defective cartridge?


PeterPaul

  stlucia 08:53 04 Apr 2003

Have you tried cleaning the print heads several times? As Woodchip suggests, a test page will tell you if they're all working properly.

I find that quite often the first or second clean doesn't produce a perfect test page, and with photos it shows up more than it does with colour documents.

  PeterPaul 16:46 04 Apr 2003

Thanks to stlucia and all - the problem was a blocked nozzle on yellow. I had misunderstood Woodchip's suggestion on test page and printed a B&W text test page. The Epson printer utilities showed up the missing yellow and a nozzle clear solved the problem.

Thanks again - much appreciated!


PeterPaul

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?