ColdFusion/mySQL problem.

  AcidBurn7uk 15:36 08 May 2004

OK, so my mate started playing with ColdFusionMX the other day but has problems.
He has created the datasource within CF administrator to connect to a mySQL database called 'Tests'

CF says that the connection is fine, which is great. The problem arises when he tries to create a record set within Dreamweaver. He selects the datasource from the drop down box, and as soon as he does this it asks him to enter a username and password. He says he has tried all combinations of passwords but they all throw back an error box which simply sais


He has also tried to create an ODBC datasource from Control Panel and the connecting to that, but it just gives him the same error!! (or something, I'm not a whizz with databases)

He can connect to CF's "built in" databases fine, and to the database of CFNuke that he downloaded from hotscripts fine. It only seems to be when connecting to mySQL.

Any help please, Regards Jay (On behalf of my mate John ;)

  Taran 17:04 08 May 2004

Can he access MySQL using traditional means and create, amend and otherwise manipulate standard MySQL databases ?

I suspect he's not using the correct MySQL username and password combination.

  AcidBurn7uk 23:28 08 May 2004

Yeah he can still access mySQL, using php, phpmyadmin and though a DOS prompt! Within CF he says he used the username 'root' where it asked for it because his other usernames didn't work, using root when Dreamweaver asks for it shows the same error message!!

  Taran 23:33 08 May 2004

root is the default username for MySQL and for local testing it should be left well alone unless you know what you are doing.

Does John have a MySQL password set up at all ?

When he uses phpMyAdmin is he required to enter a password and/or has he got a password stored in the <Install-Location>\phpMyAdmin\ file ?

I'm a bit disturbed when you say that in ColdFusion he had to use root because his other usernames didn't work.

  Taran 23:38 08 May 2004

Sorry, I hit "Post response" before I meant to.

Tell John to go to a Command Prompt.

Next he should change to the mysql\bin directory and type in this command:

C:\www\mysql\bin>mysql -u root mysql

Press the Enter key.

Note that my installation of MySQL is probably very different to his, so he will have to use the install path for his system, which will probably not be the same as the C:\www\mysql\bin> I've listed above.

As long as he uses the command:

mysql -u root mysql

he should be OK.

If he has a MySQL password set up, he should get the following error:

ERROR 1045: Access denied for user: '[email protected]' (Using password: NO)

If he has no MySQL user password then I need to know that before proceeding.

  AcidBurn7uk 23:48 08 May 2004

Thanks Taran, I will tell him this tomorrow. If Its any help though he has been messing with phpmyadmin's settings, but I don't think this has any affect on mySQL directly does it?

  AcidBurn7uk 12:54 09 May 2004

Hi, this is John. AcidBurn has kindly told me his username and password, for convienience sake, I guess I'll have to sign up once this has been sorted out!

I tried your suggestion Taran, and bing, it let me access mySQL. I then set up a password though the command prompt ant tried without password, and it denied access. Worked fine with password. Then I tried to access it though phpmyadmin, which it didn't let me. I then changed the default blank password in phpmyadmin config file, but it still wouldn't allow me to access it!!! And the same in CF, when trying to connect to an existing datasource which I know worked absolutly fine with the username 'root' and no password, didn't work with the password that I set up! I then deleted thephpmyadmin files and tried a fresh install of it, altering the password in the config file, but to no avail.
Please help as this is an intimidating start to a coldfusion n00b!!

  AcidBurn7uk 12:57 09 May 2004

Forgot to add, I can't access mySQL using PHP either!! I am going to try and delete the password and see what happens!

  Taran 13:32 09 May 2004

If you assign a password to MySQL you have to duplicate that password in the phpMyAdmin\ file if you want to use phpMyAdmin to manipulate your MySQL databases.

You will be best off if you restart your server or your system to make certain the web server is reading all files properly. This should be standard practice whenever you mess around with a config file on Apache, PHP or MySQL. IIS is easy; you just restart the World Wide Web Publishing service in Control Panel, Administrative Tools, Services.

You don't need a password to work with MySQL locally, but it can help if you set it up with one that reflects the password on your web host account, which will save making any drastic changes to your code if and when you are ready to upload to your live account.

Questions for you:

Hw did you intall PHP and MySQL ?

Did you download the individual programs and set them up or are you using something like phpDev ?

If you downloaded and installed them yourself, which order did you install them and did you install the cgi version of PHP or did you use the Zip file and extract it manually ?

Are you trying to connect to MySQL with ColdFusion via ODBC ?

I'm assuming you installed ColdFusion into IIS on Windows 2000 Pro or XP Pro. If not, are you using the built in server that ColdFusion has ? It could help if you let me know.

The final point: during installation ColdFusion prompts you for a password for the ColdFusion Administrator and ColdFusion RDS service. Are you certain that you're using the same password(s) you used on initial setup ?

  AcidBurn7uk 14:11 09 May 2004

OK Taran in order:

1) I installed php and mySQL using the windows installers.

2) I installed php THEN mySQL.

3) I have tried connecting to mySQL with CF by both, standard 'direct' mySQL connection an ODBC (I downloaded mySQL ODBC driver 3.51)

4) Bad assumption. I am actually usin XP Home, as I only actually use my server for testing before site go out live. During the CF install process it gave me an option to install along side apache, or as a standalone webserver. Installing along side apache just kept returning page cannot be found errors, but installing as a standalone server, worked fine. Although it wasn't untill afterwards that I realised I never did restart Apache!!

The final point: Yup, I used the same passwords for all (checked the box that reads something like "Use same password as above")


mySQL = 5.0.0 alpha :S

PHP = 4.3.6

Apache = 2.0.49


  AcidBurn7uk 14:12 09 May 2004

ooppps, if it's any help, I also followed the tutorial at click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Black Friday Deals 2017

Black Friday Deals for Designers & Artists: Adobe, Apple, Corel Painter, Microsoft Surface, Wacom &e…

Best Black Friday Apple Deals 2017

Black Friday 2017 : date, sites participants & bonnes affaires