Cloned HDD boot problem

  alacrity 09:48 02 Oct 2008
Locked

Having decided get a newer and bigger drive for my XP pro installation I went out and bought myself a 250Gb (Hitachi deskstar P7K500) HDD and an Akasa 3.5”HDD enclosure.
Took the drive to be cloned out of its machine, popped it into the USB enclosure, plugged it into my other computer and copied a drive image onto ‘the other’ computer using DriveImage XML. Then took the old drive out of the enclosure and put the 250Gb drive in, used disk management to set a primary partion of 50Gb, set the rest of the drive as an extended partition and filled it with a 184Gb logical drive. Formatted both the 50Gb and 184 Gb partitions and set the 50Gb as active.
Next I restored the image file onto the 50Gb partition, removed it from the enclosure, set its jumpers to ‘master’ and connected it to the end of the ribbon in the old pc’s case, disconnecting the primary’ and connected it to the end of the ribbon in the old pc’s case, disconnecting the primary slave at the same time to avoid confusions.
Powered up, entered set up and see that the drive is being seen by the BIOS correctly and is also seen as Primary Master, then confirm that boot seek is 1st HDD0, 2nd HDD1, 3rd CDROM, so far so good .
Restart only to find PC won’t boot from my HDD. Re-started with XP installation disk and logged onto the C: drive through the recovery console, so at least the recovery console see recognises the content of the C:\WINDOWS.

Googled for a while on my laptop and thought it’d be worth trying Fixmbr so typed FIXMBR, nothing hppend.

What’s happening and how do I rectify it?

  baldydave 10:10 02 Oct 2008

you could try the command FIXBOOT,use method you used for fixmbr but use FIXBOOT command

  alacrity 12:47 02 Oct 2008

tried that, no change

  alacrity 17:19 02 Oct 2008

Whilst on the subject of FIXMBR and FIXBOOT, can anyone tell me how to input the full command (i.e. FIXMBR device etc) for both FIXMBR and FIXBOOT.
The drive is on IDE0 and the OS is located on the primary partition of the primary master, i'd like to make sure i'm typing them in correctly!

many thanks

  baldydave 20:22 02 Oct 2008

try this
click here

  baldydave 20:38 02 Oct 2008

If all else fails.
You could do a repair if you have a xp cd!
boot from cd follow instructions when you get to the recovery option DONT take this option but continue you will evevtually be given the option to repair an existing windows os take this it will look like it is reinstalling but it is just overwriting system files no data loss,you will need serial no: to do this.

  alacrity 01:03 03 Oct 2008

Thanks Baldydave, Getting closer!!!
First tried to repair install, however the previous (cloned) installation was not detected so the option to repair was not available.
Have attempted to rebuid bootcfg and now I do get the option to repair (did try to boot but PC didn't find OS on IDE and went on to CD-ROM).
Attempted to repair installation and initially it looked promising, previous installation detected and files copied (so far so good) however when windows re-started during the repair process PC failed to recognise OS on IDE and went straight to CD-ROM again!!!!!
It almost seems to be a problem with the HDD, i.e. sector 0 not speaking up for itself so i took the drive back to PCworld and exchanged it for another one, same problem. replaced IDE ribbon cable as well, still same problem.
BIOS is definately seeing the drive correctly and if I connect the drive to another PC (via USB enclosure) I can access the drive.
Will continue to attempt repair install (hoping that something will drop into place, in the meantime I'm rather confused.

  baldydave 10:14 03 Oct 2008

Might be of help towards the bottom "possible fix recon boot ini"
click here

  alacrity 11:12 03 Oct 2008

Hi Baldydave,
Out of curiousity i ran CHKDSK this morning and found "one or more errors", so ran CHKDSK/R, will see if that helps, it seems that the HDD is not storing .ini files (with the repair setup.ini or boot.ini)
If this doesn't do it i'll try the 2nd method detailed in the link you posted, thanks

  alacrity 14:15 03 Oct 2008

Tried the above, no joy ***[email protected]**[email protected]@£!

When i enter "attrib -h -r -s C:\boot.ini del C:\boot.ini" it replies that the parameter is incorrect, am i entering the line correctly???

connected old drive to see what happened, booted first time, somewhat confused now

  woodchip 14:23 03 Oct 2008

If you got errors with the disc check, then the clone would not work right. Are you sure this is a new drive?

You need to clear the drive. Fit it as Slave to Original Drive then use XXCLONE click here to copy to slave drive then change them round.

You need to run CHKDSK/R on the drive before the above and after you have cleared the drive

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?