chkdsk / autochk does not run on start up

  boot-it-out 14:18 28 Oct 2008

Here's a challenging chkdsk problem - anyone have any ideas ?

Having checked the Helproom forums there are lots of problems where people want to disable chkdsk from running at boot up ( ie autochk ), but I have the opposite problem on a Windows XP Pro machine.

This all started after a power cut while using the PC, which on next start uop reported that "Windows has recovered from a serious problem..."

I have run sfc which found lots of system files that were corrupted and which were all restored from the Windows CD.

The "fsutil dirty query C:" reports the C: drive to be dirt. I can run the read only version of chkdsk from a command prompt, which reports finding "free space marked as allocated in the volume bitmap", and "Windows found problems with the file system", but I cannot get chkdsk to run and fix errors, with the usual message saying some files are in use - would I like to schedule chkdsc to run on next start - I answer yes and restart but chkdsk doesn't run, and the c: drive remains "dirty"

Over to you fantastically clever techie people :-)

  birdface 14:27 28 Oct 2008

Have you tried .my computer.right click c drive.and press properties.Tools.Check now.and tick both boxes then reboot to see if it starts.Maybe try a defrag whenever.

  crosstrainer 14:29 28 Oct 2008

Perform a REPAIR installation following the detailed step by step here:

click here

Make sure you follow these exactly, and you should not lose data. You will have to re-install updates though.

  MAJ 14:39 28 Oct 2008

Try running:

chkntfs /C C:

from a command prompt, boot-it-out.

  boot-it-out 08:58 29 Oct 2008

Thanks for the replies so far ...

buteman - Yep tried that - checking "Automatically fix errors" won't allow it to run but scheduels the autochk at boot up, which then doesn't run.
Defrag won't ever run while the disc is marked as dirty.

MAJ - You got the syntax wrong, but I have tried running "chkntfs c: /c" which would run autochk on an excluded volume - still no joy.

I have now managed to run chkdsk from a command prompt and it reports "unrecoverable errors" :-(

crosstrainer - will have a read of the instructions and try this later - cheers, but am thinking it may be time for a new drive if the errors really are unrecoverable !

  MAJ 10:28 29 Oct 2008

The syntax is correct, boot-it-out, but no matter, if you are receiving "unrecoverable errors" then a new drive looks to be the way to go.

  boot-it-out 15:28 29 Oct 2008

Thanks again MAJ - I really appreciate the help - I wasn't meaning to criticise, but on the Microsoft Tech Net site it says you should use :

"chkntfs c: /c" to restore a previously excluded volume, whereas you stated to use :

"chkntfs /c c:"

Does it make any difference ?( both return to a c :> prompt afterwards ).

Anyway I have tried them both without further joy :-(

Final thing - is re-formatting likely to restore the "unrecoverable errors" or not ?

Thanks again.

  T I M B O 15:29 29 Oct 2008

1) right click C:
2) click properties
3) click tools tab
4) click check now
5) then put ticks in both boxes
6) then click yes when the pop up comes up
7) reboot pc and let it finish till it reboots back into windows

  MAJ 15:40 29 Oct 2008

I was using 'chkntfs /?' from a command prompt to check the syntax, maybe they both do the same thing.

If the "unrecoverable errors" are due to corrupt files, then yes, a format and reinstall will probably solve that problem, but if they're due to drive sector problems, then a format and reinstall wont fix the problem sectors. It's the latter case that will mean that you'll need a new hard drive. Does your drive's manufacturer's site have any diagnostic software that you could run on the drive to check out it's integrity?

  boot-it-out 16:03 29 Oct 2008

Fantastic response times here :-)

Cheers MAJ - Just downloading Western Digitals diagnostics...

Timbo - That's what buteman suggested - it didn't work, but thanks anyway.

  T I M B O 16:19 29 Oct 2008

If chkdsk did not work, then i would be worried a bit. If you have the original xp cd then try and "sfc /scannow" you need to put this command into the run.

Best of luck............

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?