Changes to drive letters

  exdragon 19:59 30 Mar 2004

Hi - I've got Win98SE and have just had an internal card reader installed as well as some USB ports. I've just realised that, where I previously had my zip drive on E and the CD and CR/RW on F & G respectively, I now have E to H allocated to the four types of memory cards. I can't use the CR drives.

Before I take the machine back, is there anything obvious and easy that I can do to put this right, please? Emphasis on the easy...

  exdragon 20:25 30 Mar 2004

I've just spotted the earlier question about a 7 in 1 reader (didn't look for the right thing in the search facility). I've had a look in Help, & it says to go into Settings in Device Manager and allocate another letter.

However, the CD drive doesn't have a letter shown and the reserve letters available in the drop down menu are only E to H. The CD writer also doesn't have a letter shown, but the drop down menu shows start letter E and end letter F.

Anyone any suggestions, or is it a return to the shop?


  the-george 20:49 30 Mar 2004

1. Choose Start/settings/control panel
2. click on 'System Icon'
3.Click on 'Device Manager' tab and select the 'View Devices by Type' option
4.One of the icons will be labelled Disk Drives - double click it to show a list of all the 'drives' present - the same applies to CD-ROMS etc.
5.In that list select the drive whose letter you want to change e.g. your Zip then click on the 'Properties'box at the bottom
6.In the Properties window select the 'Settings' tab and you will see the'Current Drive Letter'
7. If the box containing the drive letter is white then you can enter a new drive letter to take effect the next time the Pc is started - the drive that had this letter will be assigned another automatically.
8. If the box is greyed out the process is more complicated - You will have to set the 'Reserved Drive Letters' at the bottom of the window to let the system select.

To be on the safe side make a list of all the drives etc and the current drive letters in case you need to revert.

If you have trouble getting the letters to change then try changing the letters on the cards to something like P,Q,R & S temporarily to free up the other drive letters. You can change them back to 'better' letters later.

Good Luck

  exdragon 20:55 30 Mar 2004

Thanks, the-george. I've gone into the Properties, but although the boxes are white, I can't enter anything except E to H. In the back of my mind, I seem to remember something about having to make sure that more letters are available in the BIOS settings - does that sound reasonable? If the last letter in there is shown as H, I presumably need to extend it to J? If I can remember how to get into the BIOS, that is...

  exdragon 22:41 30 Mar 2004

Anyone else any comments as to whether I need to dive into the BIOS? Logging off now, but I'll check tomorrow.

  powerless 22:47 30 Mar 2004

No need for BIOS.

  arricarry 22:50 30 Mar 2004

Do you have the drive letter manager in the Iomega software.

  exdragon 08:19 31 Mar 2004

Powerless - is there another way to do it, please?
arricarry - can't find it

I'll ring the shop later, but thanks anyway. I'll leave this unticked for a little while.

  Tog 11:40 31 Mar 2004

Are you using a tool like TWEAKUI? There is an option to only make certain drive letters available under TWEAKUI.

  exdragon 11:47 31 Mar 2004

Problem solved - I was half right about setting the last available drive letter, but it was in DOS, not the BIOS. The guy in the shop changed it from H to Z, so now I've got everything I need.

Thanks one and all.

  the-george 15:33 02 Apr 2004

Glad to see that your problem was solved but how about giving details of how to go about changing available drive letters in DOS!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?