Cdrom not recognised (Win98se)

  greybeard 14:50 19 Jul 2009
Locked

I've recently swapped hdd's between two desktops, one running ubuntu/emc bundle as a machine controller, the other running win98se as a graphics system.
The new machine system is fine, but the win98 has given me a problem.
When booting up, the cdrom appears in the first screens as a primary slave, but the drive doesn't appear in Explorer, and I can't access it to update other driver problems with my 98 disk.

In device manager the cdrom doesn't appear, and shows that I have a problem with the ide controller. I've reset the bios to the default values for the moment, as in its previous incarnation the mobo needed a lot of bios tweaking while trying to improve the latency values.
(Full details of my set new setup available if needed.)

Windows runs a search for PNP devices and shows ATI VGA Wonder(my video board) and Standard IDE/ESDI controller as having problems, but as I can't access the cdrom I'm stuck.

Any help ?
John

  Fruit Bat /\0/\ 16:14 19 Jul 2009

Check jumper settings on ALL your drives both HDD and CD.

Make sure IDE controller is "enabled " in BIOS

  greybeard 17:34 19 Jul 2009

My early response doesn't seem to have been posted, but nothing suprises me anymore.
To repeat myself - the hdd is master and the cdrom is jumpered as slave.
As another system I have has both as master, perhaps you'ld be kind enough to tell me which is correct.
Regards
John

  woodchip 18:01 19 Jul 2009

You could try the CD on second channel set as master on its own cable

  greybeard 18:50 19 Jul 2009

I've just this minute tried that, woodchip, but to no avail.
I've also checked in the bios that both primary and secondary ide are enabled.
I've installed the invisible cdrom into a third system, and it's ok there, no problems.
I used the same cabling too, so that's ruled out.
I'm a bit stumped as to how to get the correct driver for the cdrom installed without it being available.
Unfortunately, this is the only pc I have with a floppy drive, so that's ruled out.
I'm going to see if I can move files with a memory stick, but I suspect a lack of drivers in the right place might make that a non-starter as well.
Ho hum.
John
Just thought, a lan hook up ?
Not sure what to do but it might be the only way.

  Fruit Bat /\0/\ 18:56 19 Jul 2009

Virtually all CDs /DVDs players and writers will use the same windows drivers in XP. they are in the windows\system32\dirvers\ or windows\system32\DRIVERS \ folder and are:-
DRIVERS\cdrom.sys

DRIVERS\imapi.sys

drivers\MxWI2k.sys

drivers\pfc.sys

DRIVERS\REDBOOK.sys

and in the windows\system32 folder

storprop.dll

In win98 they should I expect be in the windows \sysetm folder


try device manager update driver and install these files. to get your CD/DVD working again.

  woodchip 21:11 19 Jul 2009

some old drives windows had problems loading drivers for them

  skidzy 21:46 19 Jul 2009

is the drive actually recognised in the bios ?

If so,this might be worth a try ,though meant for the early days of xp it should not do any any harm as the latter/newer version was rebuilt specifically for xp.
Im pretty sure ive used this before on 98se and it worked,however if your drive is not recognised in the bios...i doubt it will work.

CDgone.reg fix click here

You may need something like 7zip to open the zip file.

  greybeard 23:03 19 Jul 2009

Skidzy - Yes, the drive is recognised in bios, and if I change it physically, the change is noted in bios as well.
I've grabbed that download, but that does look like the last resort !!

Fruitbat - only redbook is present in my other desktop that does work with 98.

I'll start again tomorrow, with one of several hdd's that I have, and see if the symptoms are replicated.
Night all.
John

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

What is ransomware and how do I protect my PC from Petya?

Microsoft Surface Studio – the artist's hands-on review

Original iPhone review

Comment mettre à jour Kodi ?